Spacing between paragraphs

Hi. I'm using Joplin (1.7.11) on Windows 10 and have a very basic question, but I haven't been able to find the answer elsewhere. The objective is to have a compact WYSIWYG, right now there's a lot of white/blank space in the notes.
When using the WYSIWYG editor (which I use more than the markdown) when I press Enter for a new line/row, it also adds a blank line. I can remove the black line in markdown, but it reduces the efficiency of the note taking.
I've dug around the CSS posts to reduce the spacing between lines and I think I've had some success here (I am not close to having developer skills), but I can't find anything on why a new line (Enter) would also create a blank line. (It looks like double spacing until I open the markdown and see that it is just a blank line.)

The WYSI editor uses two end of line marks (just like Word). When you hit the return key it behaves as if you start a new paragraph in Word. So it adds a little more space. (Word shows this with a ¶ tag, which doesn't exist in the WYSI editor).
When you hold shift while pressing return the extra space is omitted. Let me know if this is what you were looking for.


@ajay This is super helpful, thank you! Do you know if there is any formatting option or code (perhaps in the userstyle.css) that I could add to change the default that space isn't added between paragraphs?

Sorry, I don't.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.