Line Spacing in the editors - can it be tweaked by the user?

Version 2.1.8 (prod, win32)
Windows 10

**Edit: the difference in rendering still stands as an issue, which I'll open as a Github issue per the developer's request, but I did figure out a) some but not all of the needed CSS (e.g. margin-bottom for the p tag), and b) that I needed to save the CSS file after closing Joplin. I would still like to know what CSS is needed to make the space between two lines of text smaller. That remaining question may need a new thread.

I've been using the Markdown editor in Joplin because I like the line spacing there better than in the WSIWYG editor. However, I'd like to get the line spacing in the WSIWYG editor on par with the Markdown Editor so that I can comfortably use both. Is this a possibility, and if so, where do I set the relevant options?

I know there's a userstyle.css file but I don't know if it's applicable to the WSIWYG editor. I am only barely conversant in CSS, and the couple of mild changes I made in the userstyle.css file did not have any visible effect after restarting Joplin.

The issue is that in the WYSIWG editor, the difference in the amount of space between

a) two lines of text and
b) a line of text, a blank line, and another line of text,

is too small. Everything sortof runs together in a jumble.

Below are two screenshots of some text, first in the Markdown editor, and then in the WYSIWYG editor. Hopefully the much higher readability of the Markdown editor's rendering is immediately apparent.

Markdown editor rendering:

WYSIWG editor rendering:

That's a good point, I think that should be fixed in the app itself and not via custom css. Could you open a GitHub issue for it please?

Absolutely. Will do shortly, thanks!

I have added this thread, with a similar or related discussion about the same issue.

Hi Eduardo,
I am 99.99% that that is a different issue, because I think I know the solution--I saw it in yet another thread--and that is to uncheck the option "Enable soft breaks" under Markdown in Joplin's options screen. This is an option that is off by default. I'll post an answer in your thread.

Did you have a fix on you issue? I am facing the same issue but no response from anyone and couldn't find this topic troubleshooting in google.

For the spacing difference between markdown and WYSIWG is a issue open.

1 Like

Yes, my issue is fixed. I opened the issue on GitHub and laurent fixed it. If you go to the issue on GitHub, it shows what CSS changes he made to HTML paragraph bottom margins.

You can also tweak these yourself to your liking. In Joplin, you can go to Options > Appearance > Advanced Settings > Custom stylesheet for rendered Markdown and set your own margin sizes there.

Something else I didn't know, you can go to Help > Toggle Development Tools and then use the arrow to mouse over items to see what their element names are.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.