Some items cannot be decrypted

Servus Community,

I have multiple devices and they all sync via a WebDAV URL to an Owncloud server. The data is encrypted. On my Mac Mini at work, I updated to version 2.11.11 today and was able to continue working normally.

Then at home on my MacBook (macOS 12.6.6) I also applied the update to version 12.11.11 and have a whole bunch of items that could not be decrypted. Panic. I then clicked on Retry all in the display of the elements that could not be decrypted and everything was wonderful again.

On my Linux Mint laptop it also showed that not all elements could be decrypted. The trick with the click on Retry all did not work here. It remains with a whole set of not decrypted files. Here the version 2.10.19/Linux is installed.

Then I still have an iMac (12.6.1). I have not yet installed the update, but it still does not work, even after several starts and clicking on Retry All. Here Joplin is still installed in version 12.10.19. A whole series remains encrypted here as well.

The whole thing makes me a little worried now. Data that can no longer be decrypted is the nightmare of any encryption. I have now exported the notebooks from the MacBook to JEX files. Here all data is decrypted correctly. Are the exported data then also decrypted? I can unfortunately open them with nothing.

Does anyone know why this problem occurs? Does anyone know how to fix it. Does anyone know how to avoid this in the future?

Thx & Bye CD


This is probably related to the upgrade from AES-128 to AES-256 encryption. All clients need to be upgraded to decrypt the AES-256-encrypted notes.


To clarify, are the clients with the upgrade failing to decrypt notes? (If so, upgrading these instances of Joplin should fix the issue).

I agree that this is very annoying. Ideally, the ability to decrypt AES-256-encrypted notes would have been added several versions before the automatic switch to AES-256.


This is probably related to the upgrade from AES-128 to AES-256 encryption. All clients need to be upgraded to decrypt the AES-256-encrypted notes.

Puh, everthing is back on track. You made my day, I mean that very seriously. I got really nervous. I was so panicked that I didn't dare to install the update on the remaining devices. But that was exactly the trick.

Thanks a lot CD

Yes sorry about that. I should have first upgraded all the clients so that they can read the new encryption method, then wait a few weeks and make then new method the default.

Instead I've upgraded all the clients at once and made the new method the default immediately, which is ok if you remember to update, but otherwise would cause the issue you had.

At least no data can be lost. If a client cannot decrypt it will put the note aside until it's updated, and then it will decrypt it.


And that makes me realise this error message needs to be improved to make it clear what needs to be done (update the app)


For me just updating the app did not cause a decrypt. I opened an old client and got a "Cannot be decrypted" banner for a new note and tag created by an updated client. I then shut down the old client and updated it (Linux AppImage) but the note did not decrypt and the banner remained. I had to follow the "See the problem files" link (I cannot remember the exact text :slight_smile: ) in the banner message and press "Retry all".

Just mentioning this in case someone upgrades and it seems to have had no effect.


I opened an old client and got a "Cannot be decrypted" banner for a new note and tag created by an updated client.

Since not all elements were affected for me either and I made quite a few changes to existing elements at work after the update, that could be exactly the case. That only the elements were affected that were changed with the new Release on the first updated workstation. Somehow it makes sense...

1 Like

I ran into a similar problem, but cannot figure out how to solve this. I recently upgraded the client on my Mac to version 2.11.11 and now on Android some (new) notes cannot be decrypted anymore. The Android client is on version 2.11.31 and neither the Mac app nor the Play Store are offering any new updates. Is there something I can do to get the notes decrypted on the phone?

It looks like the latest Android version is 2.11.31, so the Android device is up-to-date. I think another user reported that clicking "try again" worked for them...

Yes, if the app fails to process an item multiple times, it will be moved to the "can't be decrypted" list, and they won't be processed automatically again. But as soon as the app is updated you can indeed just retry them all and it should work

Maybe I'm being stupid or it's just the fact of being a new user, but I don't understand where I could "retry". The notes simply show in the notebook as "encrypted" and when I tip on them nothing happens. There is no dialog or anything. Is this something I should do in the settings? Switch off the encryption and switch it on again?

What if you force close the app and open it again?

And if you go to Config > Sync Status, are there any items to be retried there?

1 Like

YES! Thanks a lot. That fixed it. I didn't know about "config -> sync status" and apparently I never scrolled down that far in the configuration.

There should be a banner but apparently it doesn't always show up. We'll need to improve this: Notify users if there are items that cannot be decrypted · Issue #8381 · laurent22/joplin · GitHub

Definitively, this did the trick to me, there were no way to decrypt on Android app the notes created/updated on the windows newer version. BTW, in my case there was no banner/error message about the decrypt issue, i just realized when I saw those "encrypted" entries in my list.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.