Homepage    |    GitHub    |    API    |    FAQ

[Solved] Permission needed... Starting... Screen in chrome web-clipper extention

Question

Which permission the extention might be asking?
Do you know anything about this problem and how to solve it?

Versions

Chrome Web Clipper Version 2.1.2
Joplin 2.1.7 (prod, linux)
Linux Mint Cinnamon 20.1

Screenshot of the problem

Steps to reproduce

  1. Install Chrome Web Clipper extension on Brave
  2. Call extension
  3. See the Starting... screen all the time.

Once you see that message, open Joplin and authorise.

auth

Seems there is a more detailed message on Firefox

message

2 Likes

Yes, this was a problem. And now I have the same message as you had and the corresponded message in Joplin. Do not know why I didn't have this several hours ago.

Solved.

Thanks!

This just started occurring in my Windows 10 installation. I haven't changed the Joplin install or the web-clipper install. I tried uninstalling web-clipper and re-installing but the problem persists.

There is no message about what permissions it is looking for. Joplin desktop seems to be running fine.

You need to update to Joplin 2.1.7

3 Likes

Excellent and incredibly rapid response.
Merci bien!

I updated to Joplin 2.1.7, I use the web clipper in Firefox, I get the permission message, I grant permission in Joplin (clicking on the "Grant permission" link). I use the web clipper in Firefox, I get the permission message. In Joplin, the message is there again. I click... ad infinitum. Running Joplin on Ubuntu 20.04. Even granting permission, I keep getting the permission message, no matter if I reload either Joplin or Firefox.

1 Like

What's the version of the clipper add-on?

Thanks for answering so promptly. Version 2.1.1 (updated June 28, 2021)

Ok so you should update to 2.1.2 as it should have a fix for your issue.

Thanks so much again, the update to 2.1.2 fixed that! Web Clipper working fine!

Thanks! Updating to Joplin 2.1.7 solved this problem!

How does one get 2.1.x? The changelog shows 2.0.11 is the latest version.

nm, 2.1.2 is the extension version. Which I have (2.1.2), and I'm still getting the "permission needed" message.

1 Like

Why did this happen?

For some reason it takes a while for the installer links on the main page at Joplinapp.org to get updated.

Best location for getting the current version is GitHub

It updated today and all is well. Thanks!

@laurent , Could the changelog be updated if the current text is out of date now?

https://joplinapp.org/changelog/

Joplin wanted to update from 2.1.7 to 2.1.8 on my computer. The warning about not installing this version if I use the web clipper is still present. I have not updated because I rely on the correctness of the warning.

Curious...
On Win10, I have clipper 2.1.3 and joplin 2.1.7 but I still get a permissions error
image
Clipper service IS enabled.

2 Likes