[solved] Lost annotations while using two profiles

Hi,

I recently added a new profile and I just observed that almost all notes where lost, no plugins are installed and joplin cloud sync is not anymore configured. I don't know exactly when this occured because I was scarcely using joplin recently. Is there a already known problem of this kind? I was not able to find on the forum.

It seems that I have big backups files (349,9 MiB) that make me feel that I may still have all my notes. The last one was made on november 24th. Now, I just wonder what would be the best recovery?
An empty profile that would get what may still be on joplincloud or importing the last backup before synching with joplincloud? Any hint about that?
Is it possible to know things about what is on joplincloud like number of notes?

It saw this with joplin 2.8.8 on archlinux (Linux manulemalin 5.18.16-arch1-1 #1 SMP PREEMPT_DYNAMIC Wed, 03 Aug 2022 11:25:04 +0000 x86_64 GNU/Linux)
The package is joplin-appimage from archlinux.

I'm not so sure if it's the problem I guess. All profiles are standalone to each other, you should first check the old one:

  1. Go to File > Profile > Select Default(If you didn't changed the profile name, it should be Default)
  2. All your notes should be here in this profile.
  3. If you can't see them, please go to the notebook panel and click Notebooks to show them out.

Indedd, both profile are (almost) empty, the new and the old one!

Well, I don't know what happened but notes, modules and synchronization appeared now correctly. Strange. I don't know if can switch the topic to status solved.

1 Like