[SOLVED] Cannot Paste Images / Screenshots from CleanShot Screetshot Grabbing Software

Operating system


Joplin version


Desktop version info

Joplin 2.14.22 (prod, darwin)

Client ID: 679f4fe997f243a6b9c6f417722d30a6
Sync Version: 3
Profile Version: 46
Keychain Supported: Yes

Revision: e579eb9

Backup: 1.4.0
Favorites: 1.3.2

Sync target



Markdown Editor

What issue do you have?

I cannot paste images into the Markdown or Rich Text editors. Image files in the clipboard cannot be pasted into the editor unfortunately. It does not work when I copy an image through Finder (MacOS file explorer), nor does it work if I take a screenshot. I can paste these images into other applications just fine (e.g. Gmail editor, Evernote, Apple Notes, MS Word)

I can however, drag and drop images into the editor just fine.

It should work. What message does it print in the console when you paste? joplinapp.org/debugging

No message is printed when I try to paste in Markdown editor.

In rich-text editor I get:
09:58:41: TinyMCE: onPaste: pasting 0 resources

On a separate note, when I copy an image file from the file explorer, and try to paste it: it pastes the file name as text.

We need a specific case to narrow it down. From what application you're copying from, and what data (text, image, etc.) and to what editor you're pasting, whether it's Markdown or Rich Text

I was able to solve this issue thanks to your insightful response. It turns out my issue was limited to the screenshot grabbing software that I am using: the name is "CleanShot"

The reason for the issue was that when a screenshot is taken, CleanShot commits both the image data and temporary image file into the clipboard. When pasted many applications know what to do with this, but Joplin could not paste it.

I changed this default behavior on CleanShot to only copy Image data into the clipboard. See screenshot below. This solved the pasting issue on Joplin.

Thank you Laurent!

1 Like

CleanShot setting referenced above:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.