Unable to copy/paste images

Joplin ver 2.6.1
MacOS Big Sur 11.6.2

New install of Joplin (first time user)

I have been copying/pasting from my Memoir app without issues until I came to an image. I couldn't get the right-click copy/paste to work. So I got the original image, opened it in Preview and tried right-click copy/paste and I get this:

I tried dragging and dropping the image from my computer and I get this:

Since I am new, I'm sure it's a setting I can't find. Any help is greatly appreciated. This app is the best!

1 Like

Those links are what images look like in Markdown. Joplin has taken the file you pasted, saved a copy of it to your resources folder, given it a unique file name and added a reference to it in the note. See Markdown Guide

The picture should show up in the preview pane or rich text editor. You could even install the rich markdown plugin if you want it to show up in the markdown editor.

1 Like

Thank you so much! Being new to the app, I didn't know what the preview pane was for (it always looked like the text I was copy/pasting from Memoir! Phew!

For the most part it will be (at least with just unformatted text), the preview windows only starts to shine when you start applying formatting and structure to your notes.
If you aren't familiar with Markdown it is worth reading up a bit on it, there are a few rules you need to remember but once you do I find it really easy to use and write notes.
The guide I linked before and the welcome notes you get when you first start Joplin I think are both really useful in explaining what it is and how you can take advantage of it - even if you end up using the other (rich text) editor it is still worth keeping these rules in mind because that is what Joplin to save all your notes.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.