Shortcut for creating notes using templates?

Hey, new to Joplin.
I thought the insert template would ... insert a note using x template in the specified notebook, but it doesn't seem to do anything for me.
So my question is: what does it do?
And if there isn't a hotkey to do what I described above, would creating such hotkey be useful?

Insert template will insert the template text into the currently open note.

You're looking for "Create note from template" Which can be accessed under File -> Templates -> Create note from template. I imagine it probably makes sense to add hot keys to the Create note functions, or at least allow users to bind their own hotkeys via the options menu. If you make a pull request for that I'm sure it would be accepted.

1 Like

Will do.
However, inserting template in an opened note doesn't do anything for me. I will check again later.

Might be a silly question but also might not. Have you actually made a template? i.e. do you actually have a .md file within your template directory?

Yes, if I view my templates they pop up and stuff. So I'm assuming yes.

Ok, just wanted to make sure before anyone tried leading you in circles whilst missing the obvious. For me, if I go to Templates > Create note from template it will indeed create a new note in the current notebook using my template markdown. Likewise the insert template option will plonk it right into the middle of the note I'm currently editing and it works in both markdown mode and rich text mode.

I don't suppose there is an issue with your templates is there? Have you tried making one with literally just a single string of text and seeing if you have issues with that?

Yep, nothing happens. I restarted Joplin, but no results.
Just to make sure, you create a '.md' file into the templates folder.
Within that .md file, I typed '# test.' If I insert this template into an existing note, should it say 'test' in a heading format? For me, nothing happens.

Side question: In Docs, if you type something wrong and right-click it, it will replace the miss-spelled word with the correct one. However, (for me at least), in Joplin, right-clicking the miss-spelled word doesn't change the word itself, it just lists the correct spelling for me to manually type it in. Is this a bug?

What version of Joplin are you using? There was a bug with inserting templates in version 1.6.0. It got fixed in a point release. I don't remember exactly which one but it works now in 1.6.8


That's the problem. You should update your Joplin version. Here is the bug report and the bug has been fixed. Insert template not working in 1.6.6 · Issue #4339 · laurent22/joplin · GitHub

Oh sorry.
How would you update it, do you just download it again? Would that not reset your settings, or am I missing something here?

Thank you.

On Windows you just go Help > Check for updates and it will prompt and download the latest version.
On macOS it is the same but over on the Joplin menu (I think...)
On Linux you should run the update script on the Joplinapp website.
You can also go to your options/preferences > application and tick "Automatically update the application". I don't believe this force updates, merely checks and prompts you if a new version is detected.

The Linux version also has "check for updates" under the help menu.

I use this command line to do Joplin updates on Kubuntu (Linux)
wget -O - | bash

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.