[Resolved] Unable to view images in Joplin

when I try to add an image, they don't show up in the "viewer" pane in Joplin windows (every version I've installed since late July), I just get the broken picture icon.

I have the files in directory, I click the paper clip in Joplin, browse to the image (.png file), select it, and it fails to load. This is how it shows in the markdown:

So, I checked, and it does add the file to the resources directory. (testing multiple times adds multiple copies to the resource folder, as expected, although it would be nice if it used a CRC hash or something to prevent duplicate items from being cached...)

I tried dragging and dropping the image from the resources folder into the note, and I get the same result, except it looks like this in the markdown:

and now I have a second copy of this image in my resources directory, but still cannot view it from the note.

So, now I tried copy/paste of the image, opened in a browser tab, right click copy, then ctrl+v in the Joplin note...



and I have 3 copies of the image in the resource folder now.

anyone can help?
This has happened on 4 different computers, probably 5+ different versions of Joplin as well, I'm sure I'm just doing it wrong, but have no idea what "it" is so I can fix it...

the long part

I have been waiting for a reasonable replacement for EverNote since their "You only get 2 devices unless you pay" business model came out and I quit using it. Simply because I have a phone, a laptop, and a desktop...

One day this past summer at work, I heard a vicious rumor that the company I work for was dropping Confluence, because of the way they store their data "could", "IF" a new vulnerability was found in AWS, allow a malicious person to gain access to the data simply by having access to another company's Confluence instance. This made me laugh until I realized I had spent the better part of the previous 18 months migrating all of my notes out of One Note and into a Confluence Space... :frowning:

A co-worker of mine wrote some Python code to web scrape a Confluence Space out into word doc files because of this, pretty cool. I used that to get word files, then used a VB macro in Word to convert them all to DOCX files, so I could use PanDoc to convert them to MarkDown files, so I could import them into Joplin. No issues getting that all done, and besides having to clean up all of the pages manually (took me 3 months now, just finished tonight), It all came out good, except I cannot view any images in Joplin.


What version of Joplin is it? I think there was this bug in an earlier release but it should have been fixed.

sorry, I thought that info was in the post, I have 1.0.117 installed now, and I have upgraded at least 4 times since June, and it has not worked since I started importing my notes in June. IT does not work with newly created notes, or ones I have converted and imported.

If it is something in the way the link is being created, I don’t mind manually modifying the links to get them to work, so any suggestions are welcome, or even if someone can show me what their links to images look like. I have tried jpg, jpeg, bmp, and png files. I have tried adding them from c:\temp and from the resource subdirectory of joplin.

Which also leads me to ask if there is some way to check if a resource being added to a note already exists to NOT create a new copy, but to link to the existing. As I noted previously, Joplin just continues to duplicate a resource if you add it to a new note.

Could you open database.sqlite in an sqlite browser and check if a resource with this id exist? Also is the resource file with that id exist in the resources folder of your profile?

yes the file exists, the image in the original post is a screen shot of the resource folder, but I have good news, and bad news.

I just got 2 co-workers to test this notebook.

1 - The guy using MAC OS can view all the images fine
2 - The guy using windows (same as me) only gets broken image icons

I have the notebook sync’d to a local github repo, then I push the changes to our github enterprise site, and the other two guys pulled the repo down to test (with their joplin set to sync with their local repo version).

this syncing process with github is working good for us, but both windows clients cannot view images.

sry to double post, but I didn’t want to put this in an edit…

I can provide the note and images for one of the pages having the issue if you would like for testing. So far I have not found a Windows version of Joplin (tested on both Windows 10 and Windows 7) that does not have the issue, but the one Mac user I had test, did not have any problems viewing the images.

Yes if you could provide for example a JEX file that always replicates this problem that would be great.

here is a .jex file of a note I just typed up that is displaying the same issues (using screenshots of another note having the issue, just in case it views properly on your end. Because it works fine on Mac OS, I am wondering if there might be a permissions issue with the resource directory…

For some reason I don’t have a security tab on my Win 10 machine, but on the Win 7 machine I tested on, the user and system have “Full Control” on the Joplin directory and all sub items and folders.

I opened that .jex file on my linux laptop, in a clean install of Joplin (current version) and it works fine. No issues, so it might be something on the Windows laptops that is preventing it from working, but for the life of me I don’t see what…

If there is a permission issue or something else, will the Joplin CLI show it to me? or not, because it doesn’t have a viewer mode? (I don’t know, haven’t looked into the CLI at all)

Yes it’s working fine for me, on Windows:


Could you try to run the app in debug mode as describe here. Then can you check the log and console after you import the JEX file and see if there’s any error in there?

Also could you try to start the app with a different profile location (in case it’s some permission issue)? You would do this with joplin.exe --profile d:\path\to\profile. Note that it will be like starting with a completely fresh install of Joplin but your existing data won’t be lost - it will still be at the default profile location.

haven’t gotten any further, but the images loaded when I set the profile location to c:\temp

I did not see any errors in the console output from the debug tools, lots of information, but no warnings or errors. I've tested a couple of other Windows machines and it works if I redirect the profile outside the AppData location. Currently I am using C:\Joplin\profiles as the location for each of my profiles and I have no issues there. I had a feeling it had to do with something on my device when I could not find ANYONE complaining about it :slight_smile:

Obviously nothing wrong with Joplin, and I have an acceptable work-around in place, put resolved in the title. Thank you for helping me figure it out. I was unaware you could put a path in with “–profile”