Android lost access to resources

On Android.

After trying to long press and share an image from a note, having Joplin freeze and needing a force-stop, all my notes are now missing their images. No errors in the log when trying to access notes. It's almost as if there's a lock of some sort, but I restarted the phone and have no improvement. Any ideas?

Not just images: all resources.

Never saw anything like this after months of use on Android. Any ideas how to fix?

If you have sync set up the easiest is probably to reinstall and sync from scratch.

Before this use the export profile function and once you've exported the profile check the .resources folder to see if there are any files there.

Have you checked logs? Anything suspicious there?

Thanks. Reinstall and simple re-sync worked. I did check and found that in fact the .resources were all missing. How could they have all been deleted from the mobile app? It's a great thing that change wasn't synced, but that possibility had me worried.

I've exported a log and will take a closer look. In the meantime, any idea what sort of bug could cause an attempted "Share" invocation (or anything else) to delete all Android resources? This is a nasty bug!

I have an idea actually. Do you remember the resource you've shared before this happened?

I replied in a private message with the exact resource that seemed to cause the issue.

I have lost access to all the images in Joplin on on my Android phone (Moto G5sPlus), they are available as items in the Dropbox sync account, and Joplin is working fine on my Linux PC (Manjaro - Cinnamon desktop).
The structure of notebooks and the text of the notes is still intact on the phone.
I tried to follow the advice given earlier in the post and exported the profile, but it failed to do so and I got the following error message :-
"Could not export files: Could not read directory: /data/data/net.cozic.joplin/databases: Folder does not exist."

It did create the target profile export directory successfully.

I do not know the exact trigger for the loss of the images, but a few days ago I did try to share some data between WhatsApp and Joplin, but in which direction, I can't exactly remember. It did fail to work, I didn't notice the loss of images until yesterday.

I have successfully exported log files and they reside in /storage/emulated/o/Android/data/net.cozic.joplin/files folder.

What is the safest route to repair please ?

Clean the data or reinstall Android app completely and then sync with Dropbox again.
The fix for this is in review atm.

Thanks, roman_r_m.

It took me a while to realise that the data is not deleted when the app in uninstalled from Android. Each time I re-installed Joplin, the problem data was still there.
I list my recovery steps below to help anyone else with the same problems.

The only way to clear the data is -

  1. leave the app installed,
  2. use Settings > Apps & Notifications > Joplin, and clear Cache and Data,
  3. Re-install Joplin on Android.

As I was concerned that some of the data had been corrupted on the Dropbox account, so -

  1. I deleted all the data on Dropbox,
  2. deleted all the Notebooks on Joplin Desktop,
  3. re-installed a recent backup of the Desktop PC data,
  4. re-connecting the Android device to Dropbox by following the oauth process to Synchronise it again.

Hope this helps

I think it may be because of Android auto backup feature.

No, Dropbox (or any other sync location) is not affected.

Yes, I think that you are correct on that, so my method of clearing app data using Android Settings menu is the way to go.

I had lost a note off Android completely, when I cam to need it on the 11th March. I then found it was not available on Joplin Linux Desktop either.
I restored it from my old Evernote data and used it fine. I could not understand this at all, but thought I might not have put it in the correct folder after transferring to Joplin last October. However, when I reinstated that recent backup, I found it was there again, but also with the additional extracted copy from Evernote as well.
Could the loss of resource access in Android have affected the display of the note in Desktop ?

No, I don't see how it could possibly happen. The files that are removed from Android are still recorded in the database so Joplin wouldn't try to sync them.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.