Problem with image synchronization

Joplin Version

Joplin 1.0.179 (Linux, Ubuntu)


In the synchronization settings of Joplin I chose the file system synchronization mode and use Synology Cloud Station to synch the local folder with all my devices.


If i add an image to a note from one device, it is not displayed on the others. Inside the local directory of all my devices there are two new entries:

  • local-sync-folder/
  • local-sync-folder/.resource/new-image-id

The image is also added to the ~/.config/joplin-desktop/database.sqlite of the other devices, but not in the ~/.config/joplin-desktop/resources/. Do i have to synch that folder too? Am i missing something?

Does the image look like a download symbol instead?


My first post here was just this problem. Welcome to the forums. :sweat_smile:

1 Like

Yeah, problem was that i imported some notes with images and for some reason they do not synchronize properly. Even if the download policy is set to “Always”. Problem does not occur with imported images as attachments though. Thanks a lot for your support.

1 Like

Check here to see if any of these fit your specific issue. The devs here are cracking down on duplicate bug reports but if nothing you find there helps, you can always submit a full bug report there (please include your debug log - instructions here).

Other than that, feel free to hang around here, join the Discord, and welcome to Joplin. It's got a tiny bit of a learning curve but is pretty good for what it is. :smiley:

Did you solve the issue? I found that I have to enable the sync of the folders with a prefix "." on synology application.