Problem syncing with webdav

I'm trying to sync Joplin with Nextcloud in order to use as my main note editor and I'm stuck in the syncing process. My nextcloud server is located at, as I have it through my account, which is the mobile OS I'm using. If I put the webdav URL just as it is indicated at nextcloud, it syncs well with the root folder, but once I cannot manage to sync with a subfolder (it is obviously not an option to keep all notes in the root server).
My URL looks something like this:
If I just add the subfolder name after "/files/" it doesn't find the URL. My access path to the subfolder looks something like this:" (test is the subfolder)
If I add "files/?dir=/test" to the webdav path it says it is ok while checking synchronization configuration, but when I try to sync it says:
SyntaxError: Unexpected token T in JSON at position 0
Any help will be appreciated. I really like Joplin and I would like to use it as my note editor. Thanks!

Some time back I had problems connecting to Nextcloud. I then found that using the "WebDAV" sync option in Joplin rather than "Nextcloud" worked...

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.