Print Does Not Work

I am using Jopin 2.6.10 Appimage on Linux 20.3.

When I try and print a note, the app just exits with no error message and nothing in the print queue. I have a similar issue with Typora and MarkText. All other printing from other apps on my system works properly. Export from Joplin works properly.

Any ideas?


Joplin 2.6.10 AppImage
Kubuntu 20.10

I have been getting the same. I try to print a note and the app crashes. No messages, it just vanishes. I have found that if I restart Joplin and try again it crashes again but on the third attempt it prints but crashes. Thereafter Joplin will print but it also crashes.

I tried with all plugins disabled but the same happens.

I have tried using flags.txt for debug info but as the app crashes so completely I cannot see anything appear in the console and the log just shows:

2022-02-17 21:26:27: "CommandService::execute:", "print", "[]"

as the last entry. I was going to try to test this using a clean install on a Linux VM but I do not have one set up for printing yet.

Same Joplin version on Windows 11 prints fine.

As this post has come up I thought I'd just throw in my observations now.

It's been doing this since at least the Electron 14 update, where the issue with the filepicker causing crashes was observed, it could potentially be related on the Electron side?

The filepicker bug was recently closed on newer Electron versions (of both the 14.x branch and Electron 16), so maybe this printer problem might be fixed too with a version bump.

Just found this on Joplin GitHub Issues:

and it looks like @bertradio also found it two hours before posting on the forum.

I think the problem is definitely related to Electron since I have it with Typora and MarkText as well. For me the workaround is to export to PDF and print that.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.