Homepage    |    GitHub    |    API    |    FAQ

Plugin: PlantUML

@uphy created the plugin to support plantUML in Joplin:

I contacted him to have some news about the issues created on this plugin but apparently he does not plan to continue working on it.

What is the procedure to release a new version of this plugin from another github repository?

If I use the same manifest but with an increased release version can I replace the plugin that is currently delivered?

Do you suggest me instead to create a brand new plugin (e.g. plantUML2) or to somehow deliver a new version of the existing plugin?

@laurent @tessus

2 Likes

Plugins are published to npm so unless uphy is willing to share his account you won't be able to publish a new version. Instead you'd need to resubmit this as a new plugin.

2 Likes

Is this not sufficient?

1 Like

It still requires a sign of life from @uphy

Ah, didn't know it was possible. Interesting.

You could simply fork the repo (if the licence allows) and publish under a new plugin ID. We'd mark the previous as obsolete so that only the most up to date plugin shows up.

1 Like

This is what he wrote me.

I will fork his repository and create a new plugin,
Thanks

2 Likes

I wonder whether we should transfer the plugin ID to you or not. If it was a widely used plugin we probably would, but in this case maybe it's not necessary?

The advantage of transferring the ID is that people would automatically get your new plugin as an update to the old one. What do you guys think?

Do you have any usage statistics on the plugins?
The only statistics I have comes from npmjs.com with 56 downloads when it was released.

image

Number of downloads is there:

At the end I decided to rewrite the plugin completely and here is the repository I created:

I called the plugin PlantUML2 and I implemented all the feature requested for the original plugin:

5 Likes

Sorry for my little knowledge of the subject, but I understand that this plugin replaces the one created by uphy, so we should uninstall the previous one and install this PlantUML v1.2.0, is that correct? I can see both in the plugin list, I know it is like a fork plugin but I assume is an improved and updated version of the first one. Right?

If you uninstall or disable the plugin PlantUml v0.0.1, you can then install PlantUml2 v1.2.0

You don't have to do any changes to your notes because they both use the same markdown syntax.

Please try PlantUml2 e give us your feedbacks so we can work on it to improve it.

If you think PlantUml2 in not working well you can go back to the previous version but be aware that it is not maintained anymore.

Thanks for the update @marc0l92. I guess we could mark the previous version as deprecated quite soon so that user can start moving to yours.

By the way the previous version could potentially crash the app as described here. It's an issue I've tried to mitigate on application side but it seems the exception thrown by the PlantUML lib escapes whatever boundary I set. Do you know if your plugin has this issue too?

I'm not using the same library that was used by the previous plugin version.
I'm not sure what is the example that should make Joplin crash by I tried the one in the first issue comment and the one in the attached file and they are both working on windows.

recordingGif

1 Like

That's brilliant, then it means it's most likely fixed then. Because when I've tried that JEX file earlier it was crashing the app right away.

By the way, I've added some info about making a plugin obsolete here:

https://github.com/joplin/plugins/blob/master/readme/obsoletes.md#about-obsolete-plugins

I've just realised it's something that can be done relatively easily via a pull request, so would you mind giving it a try and make the old PlantUML plugin obsolete?

Here the pull request:

1 Like