Plain text notes (disable the preview that is built into the editor?)


Joplin is great, but I would prefer it to be dumber - I only want my notes to be plain text files! They can be stored as .md, I don't mind, but it would be nice to copy paste some stuff that starts with markdown-recognized characters and just see those characters, not what markdown would turn them into if I decided to look at the preview.

For example, I believe I have disabled the preview pane as I'm only looking at a single pane which is not the rich-text-editor, but pasting some random text (I know this looks like code, but imagine if I just liked to use the # character to highlight things in my plain text files when I'm doing some writing):

plain text
# ooh, I should note this cool thing and I like using the # character to note it for example
my plain text

EDIT: oops, it even happens here so I've indented it. I just want to use Joplin as if I was writing a .txt in vim!

Into my editor, the line "#" makes the line become massive because the editor considers it as a title. I thought I could press the button to look at the preview if I wanted to see what the result of the markdown would be, so why do I need it in my editor? Can this be disabled? Both the editor and the preview doing the same thing seems odd.

Perhaps I can tag all of my notes to be default no-markdown? I guess making everything I write considered code by indenting would work, but I'd rather not indent literally all of my notes from now until forever so that they aren't parsed!

Thanks very much! I'm happy to change the code on my end if I could find the place where the editor does this :slight_smile:

Note, this is on Ubuntu

if you start your note with ``` (3 backticks) it should do the trick.

Hmm, that could indeed be a work-around, thanks for your reply!

Though it makes the text a slightly less easy to read light brown color, and adding "pre {...}" CSS to the "Custom stylesheet for rendered Markdown" or "Custom stylesheet for Joplin-wide app styles" seems to have no effect on the editor.

I think this one should work if you find the right CSS selector.

You can use the userchrome.css file to edit custom wide styles. Take a look at the below link which has a bunch of useful customizations. The first one is exactly what you want


Thanks both! The first style in the Joplin Customization link is exactly what I was looking for! Much appreciated :slight_smile:

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.