PDF preview not working

Operating system


Joplin version


Desktop version info

Joplin 2.13.10 (prod, win32)

Client ID: 69f392a57d414a40b8d2bacddcbf4a89
Sync Version: 3
Profile Version: 44
Keychain Supported: Yes

Revision: 9731936

Enhancement: 1.2.1

Sync target


What issue do you have?

I am very new to Joplin (recently migrated from Evernote) and I can't for the life of me make the pdf preview work.
I have ticked the right boxes (Tools -> Options -> Markdown -> Enable PDF viewer (wysiwyg: no) ) but to no avail.
I also have installed the "Joplin Enhancement" plugin and checked the relevant box but nothing.
I have reviewed previous entries in this forum but none of the solutions described solved my problem.

Any help would be much appreciated.




@Simon_V welcome to the forum.

You did not mention what editor you are using within Joplin. The comment "(wysiwyg: no)" means that this Markdown option does not work with the Rich-Text (wysiwyg) editor.

To explain...

Joplin lets you edit your notes in two ways: a switchable layout Markdown editor & viewer or an all-in-one Rich-Text (wysiwyg) editor.

Below is an image showing the buttons to switch between the two editors.


The blue highlighted "Layout Button" (or CTRL+L) lets you switch between different views when in the Markdown editor. Also, the menu item View > Layout button sequence lets you set what happens when you press the layout button.

Hi @dpoulton ,

Thank you for the swift and very clear response.
I have been switching between views but the pdf appears only as a link.
I have tried to re-import different pdf documents in the same note and in different notes. No change.

Here's how it looks in the Markdown editor:

any ideas what's going on?



Yes. That text on the left is not Markdown and is also not a link to a file. How did you attach the PDF to the note?

What you can see in the editor is HTML which is linking the text "2017 Sep.pdf" to "#", which is not of course a PDF file.

Either drag and drop the PDF file onto the Markdown editor pane on the left or use the paperclip icon to attach the PDF to the note. When you do this Joplin will import a copy of the PDF into its store of attachments (called "Resources"), give the PDF a unique ID and then make a Markdown link to the stored PDF. It should end up looking something like this:

I have done what you said and I have the same problem.

However, thanks to your indications I have now realised what the problem has been all along!!!

As I mentioned before, I only recently migrated to Joplin from Evernote. In doing so I have imported to the notes I had in Evernote (ENEX files) as HTML and not Markdown!!!!

I have now tried to import again one of the notebooks (containing PDFs) as Markdown and taa-daa it works perfectly.

Having to re-import all the notebooks is going to be annoying but Iā€™m glad to know that there is a solution to this problem. Do you know if there is a way of importing notebooks in bulk?? If you do please let me know, that would save me a lot of time.

Either way thank you so much for your time and your kind help. Your words were illuminating and now I understand a bit more how Joplin works.

Thanks again, :slightly_smiling_face:


I am afraid that I don't. It's a long time since I moved from Evernote to Joplin so remembering the detail is difficult. I believe that Evernote only lets you export one notebook at a time and so Joplin imports one notebook at a time and I do not believe that there is a way of "queueing" imports.

Never mind. That will keep me busy over the Xmas break.
thank you so much for your help!


I have found this GitHub issue which apparently has been fixed. It is to do with when you edit an HTML note in The Rich Text Editor it replaces the resource link (something like :/93d25985c31c4aad91d5e710390de5f1) with #. That looks similar to what you have above.

I haven't yet determined what version this fix is in or likely to be in.

Changing to Markdown notes should make using Joplin easier because markdown notes are far easier to read and edit. However there may possibly be an option for you to do nothing and wait for the fixed version to be released.

I personally think that if you are just starting out, importing again as markdown is the way to go, I just thought you may like to know that this appears to be related to a bug that is in the process of being fixed.

Another new user here.

I've migrated a plethora of stuff from OneNote hoping to wean myself from that beast.

Similar setup to the OP.

Thanks for info on how to display the pdf's.

As I've seen in other posts, you could call me a pdf-aholic. I've got gazillions of them. I currently use OneNote to organize them in to a stream of consciousness kinda thing flowing from one to the next.

The problem is honestly the pdf display in Joplin is virtually useless.

Let me demonstrate.



"Not allowed to post more than one media".... (?)

Significant difference in readability.

Am I missing something?

If not, are there plans to make this useable?

Sorry to be so critical on my first post.



Joplin version

That's odd. You appear to be missing the "hamburger" menu (1) that lets you see the page thumbnails as well as the navigation and size buttons (2).

Well, I do if I choose the Markdown mode:

But the question is, how do I get rid of the middle pane and still view the pdf?



When in the Markdown editor you can change the panes that are displayed by pushing this "Layout Button" or CTRL+L. It cycles between editor only, viewer only and both (which is what you currently have).


You can customise what panels are shown when cycling by using View > Layout button sequence. Personally I use the option Viewer / Split View. I tend to leave Joplin in viewer only and hit the button for a Split view only when I need to edit.


That will work;

Is there a way to enlarge the window of the pdf viewer?

Lot's of whitespace going to waste.



I've come to the conclusion that Joplin is just not for me.

A plethora of reasons.

Thanks to all who provided assistance.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.