Homepage    |    GitHub    |    API    |    FAQ

Only notes, no notebooks, on first sync to mobile

I recently moved a massive Evernote archive to Joplin. It imported with few problems to the CLI and desktop apps, but on first sync to mobile I get no notebooks, only individual notes. My mobile app now has 4000+ notes, all on one level. The notebooks folder in the sidebar is empty; it's as if the tree metadata is invisible to the app.

I have tried it on both iOS (Joplin 1.7.2) and Android (Joplin 1.7.5), with the same result.
I have also tried syncing from both Nextcloud and Dropbox; identical problem. Meanwhile, the same archive syncs fine to Joplin Desktop (1.7.11) and CLI (1.7.0) on Manjaro Linux.

I browsed this forum and r/joplinapp but didn't see many posts on this particular problem. I am new to Joplin, so any help will be much appreciated.

The syncronization on the mobile devices is interrupted when the app is closed or the display on the device goes out.

Therefore, make sure that the app opend and the device are on during the first synchronization, which can take a relatively long time with so many notes.

You can check the syncronisation status, total and synced items should be the should be equal and the total items should be the same on mobile and desktop.

Sync status
Mobile: Settings > SYNC Status
Desktop: Help > Syncronosation status

2 Likes

Many thanks. It worked out very nicely in the end. I didn't realise 1) that the tree structure would only appear at the end of the synchronization process, and 2) just how long the first sync would take.

1 Like