Old Version of Notes replacing current version

Operating system


Joplin version


Desktop version info

Joplin 2.13.9 (prod, win32)

Client ID: 06e60506d05f4f33adc0a7df2e90c369
Sync Version: 3
Profile Version: 44
Keychain Supported: Yes

Revision: 1bbec44

Conflict Resolution: 1.2.3
Cursor Sync: 2.1.0
Search & Replace: 2.2.0

Sync target



Markdown Editor

What issue do you have?

I typed quite a bit into a note last night and when I went to check on the note today everything I had typed the night before was gone. There were no conflicts/nothing in my conflicts notebook.

Looking at the console the only error I found was this one:
DevTools failed to load source map: Could not load content for file:///C:/Users/gregs/AppData/Local/Programs/Joplin/resources/app.asar/index.js.map: Unexpected end of JSON input

While this error has happened to me a few times in the past (the previous times being very little data so I didn't bother trying to fix it) it's not the sort of thing I can recreate. I generally make a point to manually synchronize data on my desktop app both when I open and when I close the app. I do the same on Android and avoid having both open at the same time.

Solution: I was able to restore my data using the Note History feature. Getting to the feature is a bit obtuse as you have to select the note then click Note in the menu bar at the top of the app then select Note Properties. A popup will appear and you'll see a blue link next to Note History, that opens the Note Revisions page. I found my missing data about 3 versions back with the last 3 versions being exact copies as best I could tell of a version prior to when I worked on the note before.


  • Obviously try to fix whatever bug this is though I understand it's not so easy when the problem isn't easily repeatable.
  • Add Note History to the context menu when right clicking on a note (that's the first thing I tried, looking for an obscure option on the menu bar was not).

I have a hard time understanding -> how a note typed last night could show up in the notes history "three versions back", would you please report your note history settings.

Later versions of Joplin do no longer sync every note, but do a smarter "sync when needed" job (my understanding, I am not a dev). So please consider stopping to trigger manual sync/s many times a day, and just let Joplin do it's job after setting the appropriate sync settings. Then let us know if the problem persists.

Just my 2cts.

Is the date/time correct on the Windows device (e.g. a few hours/days ahead, then syncs with a time server and has the correct time again)?

Joplin Plugins: Conflict Resolution 1.2.3, Cursor Sync 2.1.0, Search and Replace 2.2.0

Note History is 90 Days.

I haven't set anything too fancy up. Android settings are the same.

I generally only do the manual syncs (and to be clear I'm just hitting the sync button) when I first open the app and when I close it because I've had problems before with it not synchronizing on startup on Windows or not fully synchronizing mostly on Android. Android in particular seems to be bad about it I presume because it completely pauses when I close the app even if I don't swipe up to fully close it (which I generally do for privacy reasons) but only syncs every 5 minutes so if I just open the app briefly to write something is doesn't have time to fully sync. The full sync issue seems to be mostly an issue when I switch between Windows and Android too quickly (I presume it's OneDrive giving an old version of the notes before it's updated things internally though I'm also not a dev and am just guessing).

As far as I know there aren't any issues with time sync unless Windows is just being Windows. I am using Win11 on the machine that had the problem last (an ROG Ally) and Win10 on my older and bigger beast that has also seen the problem before (custom build with a Ryzen 7 5800X and an original Gigabyte RTX 2070).

I had an issue recently with a chunk of text I added to a note on Android which I later noticed had disappeared. There's no evidence of the missing text in the note history though, so it may well have been related to the input issues I had an Android due to using an old version of the Gboard app

@gnorris have you experienced this issue on the Android app or just on the desktop app?

Also when you noticed the missing text from the night before, had you done any syncs on your phone between writing and noticing the text was missing on that occasion?

I don't think I've ever experienced the issue after writing something on the Android version. I did do a sync between the time I typed the data and the time it disappeared so it's very well possible it was a sync related issue. I think the most probable cause would either be a timestamp issue like personalizedrefriger suggested (my computer is always connected to wifi but that doesn't necessarily rule out some weird time sync issue) or something weird on the OneDrive end. Services like OneDrive usually (and should) have multiple copies of data across many servers but that can sometimes cause a device to be fed an older version of a file from a server that's not received the most recent version yet. I did have some connectivity issues recently where my internet just dropped without warning, I've just updated my router and WiFi drivers to hopefully fix whatever that issue was. Not sure how Joplin handles timestamps, if the timestamp data is just normal creation/modified date meta data that could explain it (old version could have newer timestamps) though I'd think Joplin would use a method less prone to errors (not sure about other OSes but on Windows my experience with accurate timestamps for file creation is all over the place).

The note history has timestamps on the versions. Maybe if you post the timestamps on the version with the text you added and the versions after it could shed some light?

I wish I would have thought of that, when I restored the note I deleted the non-restored version and moved the restored version to the proper notebook which unfortunately means that the note history prior to restoring is gone. If it happens again I'll try to remember to check though the issues only really popped up a few times in probably a few years of using the app.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.