Old decrypted files are still on Cloud

Hey at all!

I need a little help for a problem or misunderstanding that I have.

I use Joplin since 2019, but I use the encryption feature only since at least one year. So, I already had a bunch of files lying on my cloud, before I decided to start with this.

  1. But now I saw that there are lying not encrypted files, raw, on my Nextcloud. If I open the file directly on my remote Nextcloud, I can read the content. If I open this file in Joplin, add a new character and save again (plus synching to the cloud), the same file get updated and will be encrypted. I can't read the file on remote anymore. Exactly what I want!
    ⇒ How do I remove those old, not encrypted files? Do I have to open all files in Joplin and change a character, in order to get it encrypted?

  2. On remote I have 4581 files, if I mark them all. In my local Windows folder I only have 705 files. The Total amount in Joplin states a total of 1835 (see Screenshot).
    Could the problem from my point 1 have something to do with this?

  • Sync Target: Nextcloud 24.0.4
  • Joplin Version Joplin 2.8.8
  • Windows 11, Android and Windows 10

I don't understand how the encryption in Joplin works, and can't get my head around this. How do I solve this? Why are there so many files on my remote?

Thanks in advance!


  • 2019: started to use Joplin
  • 2021: started to use encryption for Joplin

🡒 Found not encrypted files on remote (Nextcloud), can read content directly on remote. (Only old files, that weren't touched after enabling of encryption)

Question: How to remove those old not encrypted files on remote? Or trigger a fast encryption of all files?

Info: On remote are 4581 files, in Joplin 1835 and on my PC only 705 files.

If some of those files are in the ".resource" folder, they will never be deleted by the app since it won't check about such files. It sounds like your best option would be to delete everything on the sync target, then in the config screen, under Synchronisation, click on "Re-upload local data to sync target".

1 Like

Will try as soon as I'm home, don't have access from work laptop to my remote.

That's it! Thank you very much! Learned about a new feature today :slight_smile:
Thanks for the hard work, best App ever!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.