Note list disappears (updated info)

Hi all,
Since a few days my joplin window is messy.
I am used to have it setup like this:

|Notebooks| Note tabs                 |
|         |---------------------------|
|         | Note                      |
|---------|                           |
|Notelist |                           |
|         |                           |
|         |                           |

Also installed was the kanban plugin, so that in my Actions notebook the Note window is split in two.

Now for some strange reason, the Notelist cannot be placed in that location. When I do so via change application layout, it disappears upon [ESC]. Also, when placing the Notelist next to the Notebooks, it just does not show, but the notebooks list also uses the width of the Notelist.

Tried with the kanban plugin turned off, no difference.

Joplin 2.5.12,
Windows 10,
All plugins up to date as of today. Specifically: kanban v1.0.4, plus a whole bunch of others.

Update: console gives a whole bunch of these warnings:

DevTools failed to load source map: Could not parse content for file:///C:/Users/XXX/AppData/Local/Programs/Joplin/resources/app.asar/gui/note-viewer/pluginAssets/mermaid/ Unexpected end of JSON input

Not only for, but also for,,, and many more...

the logs are not up to date: last entry is of 3rd June...

Any suggestions on how to get the list back?

1 Like

Hello mabo, could you please follow our guide on debugging and enrich your description of the behaviour with logs (console and debug log)?

So far, I couldn't get the same result either with kanban plugin or without @ Joplin 2.5.10 (prod, linux). Can you remember any other actions before stumbling into the problem?

Did some more experimenting. Even with all plugins disabled, the notelist remains hidden. It shows when "Change application layout", but upon hitting [ESC] it disappears...

Have you tried removing everything from your userchrome.css and userstyle.css files?

Thanks for the suggestion.
I saved the existing userstyle.css and created a new, empty one. No change, notelist still missing :frowning:

There is no userchrome.css file in the .config folder...

On my linux laptop with 2.5.12 I have no problem either...

I do hope that the additional info from the console is of help and might point to the root cause.


As it is not clearly known what's causing the behaviour and it is specific to this exact Joplin instance, could you try wiping out the settings completely (maybe Victor could help you here) or even reinstalling Joplin?

Please make sure you have a backup and not going to lose the data in the process.

Just reinstalled Joplin. Notelist is back, but only one plugin installed.
I'm syncing now. After that, I'll one by one reinstall the plugins. I'll report any issues.

Thanks for the support


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.