Not sure what this symbol in notes means?

I'm relatively new to Joplin and have a very basic question.

Ive imported notes with jpeg attachments that show up fine on the Mac Desktop App.

On my android a symbol that looks like download appears. I've tried tapping it but nothing happens. I've also browsed settings and set attachments to download always.

I am synchronizing using OneDrive.

Below is an attachment of the symbol. Is it supposed to be a button?


Hi, in my experience it shows up when attachment is either not downloaded yet for some reason or there's a problem with the attachment: it might be deleted but the link still points to local storage.

It does suppose to be clickable to force the download of the attachment but if you're running in "always download" mode and after checking it you have completed the sync the button should be replaced by an actual attachment.

If it's not, make sure the sync was complete and not interrupted by screen lock nor putting the app in the background. Sync on mobile cannot happen at those states. And with thousands of attachments it might take a long while. So it's best to setup the screen lock for as much as possible time and leave the app working in foreground.

Hi graphit0!

Thank you for the helpful and prompt reply!

I agree. The files show up on the desktop app with the attachments so I know the files are in the database.

The "button" is not tappable on my Android. I have double checked I am in always download and resaved this setting. Ive also restarted the phone just to be sure.

I also took your advice and disabled my screen lock but things seem to be running the same. I left Joplin running for over an hour. It shows Sync Complete but under that it says Fetching Resources 3/10. Its been stuck on this the entire time and I see no way to refresh it. I've heard of this being an issue on older threads but no answers were posted.

It might be kinda overkill but maybe reinstalling the app and resyncing entire database with "always download" mode enabled could help.

If you're going to do that, please make sure you have a backup just in case.

Thank you for the advice. Ive tried what you suggested. Sync is set to always and I've reinstalled the app.

It still says Fetching 3/4 Resources and says Synchronise completed. Somehow it isn't fetching or displaying the photos in documents still.

Any other ideas on what to try?

At this point let's try a few things.

Firstly, I think it makes sense to see what the log says, you can find the button "export debug report" in the settings

Secondly, if you export your profile on Android do resources indeed there (and you can open them) or they're, indeed fail to be downloaded in the first place?

It might be helpful to see if Joplin desktop on other operating system would sync those photos.
Please check that you're running latest web view. It's not a requirement but in my experience it helps with performance and stability of the app.
Also, maybe you can copy your data to another cloud provider so we can cut off the cloud interferring with the sync.

I wonder what's the format of those photos?
Do all attachments fail to sync or only photos?
Are they unusually large?
Do you have enough space on the phone to keep them?

  1. Im attempting to get the logs. Does it have to be off the Android or the computer? Are they separate logs or is it stored on each platform?

  2. If I understad the question correctly, they aren't downloaded in the first place. They appear on the desktop app on the computer but not on the phone at all.

  3. Since uninstalling the app on Android and reinstalling it has failed to download all notebooks again. I had to baby it to do this the last time. This is what is causing the delay.

  4. The format of the photos are JPGs and less than 500kb. There is no storage issue on the phone or computer. I believe some PDFs are also missing but I would have to hunt for these as I am still using the Evernote database until this is resolved or fails.

Check your syncronisation status on both devices
FAQ: How can I check the sync status?
Have both uploaded / downloaded everything and are the numbers the same?

I think you let the phone go into sleep mode?
FAQ: Not all notes, folders, or tags are displayed on the mobile app

Yes, each device has its own logs and must be accessed on the device.
Desktop: ~\.config\joplin-desktop\log.txt
Mobile: Configuration > EXPORT DEBUG REPORT

1 Like

Thank you for the help!

I disabled screen timeout and security lock on my Android and it began to sync. Unfortunately to sync roughly 4k files (1.83GB) it took over 14 hours. Is this normal?

After the sync finished, this showed up on Sync Status.

First sync is always a little slow, it's fine.

I wonder do you use this OneDrive for anything else rather than Joplin sync?

Does it have any sync client installed on any computer/phone?

Does OneDrive have enough free space to fit the photos? I remember it's only 5gb for free account.

If you got time you may try moving to another cloud (say Dropbox if your database is no more than 2gb) for now just to see if it makes any difference

Don't forget to keep a fresh backup before moving though

I have never seen this error message before. Could you please upload the log file from your mobile device.

The amount of time depends on several factors:

  • Internet connection speed
  • Encryption yes/no
  • Performance of the device
  • Throttling from cloud provider
  • Performance of the cloud provider / sync server
  • ...

My Android phone needed 5-6 hours for 36221 items ( round a bout 4.5 GB) the last time I hade to reinstall Joplin.

I ended up hitting Retry 87 times. I think maybe it switched to LTE from Wifi and then back again.

After confirming all the files were there it seems like this is solved after a long struggle. Thank you everyone!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.