NOT similar: Link to local file with Linux Mint does not work


I am using Linux Mint 20.1 Ulyssa Cinnamon (1.1.1f-1ubuntu2.16 amd64)
Joplin ver. 2.9.17 (prod, linux)

Creating a local link does not work. I have tried to install the flatpak version normally via Mint's appstore and as --user as well (without sudo), to no avail, and I tried different user rights modifications with chmod, as root and as user and as sudo, for Joplin and the file in question. When I try to open the link, nothing happens (a pdf-file). I tried both drop and drag and to create the link manually, respecting url-encoding.

Nothing was successful.

This is what the console (Linux terminal) reports when opening joplin within:

[2 zypak-helper] Portal v4 is not available
LaunchProcess: failed to execvp:
Gtk-Message: 20:10:44.595: Failed to load module "xapp-gtk3-module"
(node:65) MaxListenersExceededWarning: Possible EventEmitter memory leak detected. 11 pluginMessage listeners added to [EventEmitter]. Use emitter.setMaxListeners() to increase limit
(Use exe --trace-warnings ... to show where the warning was created)
Check failed: chdir(current_directory) == 0
exe --trace-warnings net.cozic.joplin_desktop

I will attach the log, the relevant messages are:

joplin.views.panels.setHtml <hidden>
useMessageHandler.ts:16 Got ipc-message: file:///mnt/Daten%208TB/AAA%20Dokumente/_Schule/_MNS/Curriculum%20MNS%2056%20Endfassung_Musik.pdf 
{resourceId: ''}
Logger.ts:219 20:38:38: CommandService::execute: openItem file:///mnt/Daten%208TB/AAA%20Dokumente/_Schule/_MNS/Curriculum%20MNS%2056%20Endfassung_Musik.pdf
20:39:18: resourceHandling: Attaching /mnt/Daten 8TB/AAA Dokumente/_Schule/_MNS/Curriculum MNS 56 Endfassung_Musik.pdf
Logger.ts:219 20:39:18: resourceHandling: Error: Kann nicht auf /mnt/Daten 8TB/AAA Dokumente/_Schule/_MNS/Curriculum MNS 56 Endfassung_Musik.pdf zugreifen
    at shim.createResourceFromPath (/app/joplin-desktop/…init-node.js:266:47)
    at async shim.attachFileToNoteBody (/app/joplin-desktop/…init-node.js:345:15)

Do you have any idea how Joplin will be able to handle this?
-1671392413069.log (52.5 KB)

Ok, I did further research :wink:

A local link works fine when I use the preset home/user-directory on the same hard drive. Since I plan to conduct a new installation soon, I will then put my home directory on the different disk. If it is still an issue than, I will post an update.

Nevertheless I think it would be good to be able to link local files in Linux even when they are not stored in the designated directory, don't you think so? I will open a feature request...

P.S.: I tried several distributions of Joplin, not the one out of the store only.

Ok, for everyone stumbling about the same problem: Uninstall Joplin via terminal

flatpak uninstall -y joplin

After that go to GitHub - laurent22/joplin: Joplin - an open source note taking and to-do application with synchronisation capabilities for Windows, macOS, Linux, Android and iOS. and install Joplin with the terminal command beginning with wget - as sudo of course.

On my machine, the icon does not pop up though.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.