Enable local file link on different location then home/user on Linux

I don't think this feature was requested before...

On Linux Mint (Ubuntu), I only can link a local file to Joplin when it resides in my designated user directory. It would be great to have the possibility to link a local file from every location on the same machine, even when it is stored in the most improbable folder imaginable :wink:
(After having adjusted the neccesary rights of course)

Thank you!

Hi @woldo,

It is actually possible to link to a local file from anywhere on your computer. However, since you're on linux mint I'll assume you used the linux mint app store to install Joplin? Linux mint distributes an alternative version of Joplin with more restrictions, such as not allowing the app to link everywhere.

If you install Joplin directly, you'll have no issue

1 Like

Thank you for your response!

No, I've tried the flatpak version as well - as single user also. It's all the same. But it might be related to Linux Mint not automounting drives out of the box, yet I had it mounted and the link was right.

When I drag and drop a file from my home-folder, there is not a link like you would type it in, but kind of a symbolic link, e.g. it says :/1205c1802fad4bada9a132b3f9ad129c for a pdf file which is stored in /home/user/documents.

I've tried rights management changes, tons of options. It does not work from any drive with Linux Mint. Perhaps it's different with other distributions. this I don't know.

I've described it in detail here: NOT similar: Link to local file with Linux Mint does not work including log file and all.

Best regards,


Hi CalebJohn again,

hm, I pasted and copied the github instructions to install Joplin into my terminal after performing an uninstall with flatpak and you are right: linking local files just works. I thought I tried that before - obviously I worked too much on my machine yesterday to get it all right.

Is there anything related to chrome or firefox modules in Joplin? I updated ungoogled chromium and librewolf just before, and had to update flatpak as well since Linux Mint only has an older version packed in it's store. Neither librewolf nor ug-chromium worked any longer with the older versions, yet apt told me all was up to date, that's why I bothered...

Ok, perhaps it will help other people to read about my problems - thank you again for your help!

1 Like

No Joplin is self-contained.

The Joplin install script installs the AppImage version of Joplin, which doesn't have the same level of sandboxing controls as the flatpack version. The flatpack version is less flexible for the user, but in exchange it means that you have to trust the Joplin developers less. In my understanding, this tradeoff is true for all flatpack apps.