No Syntax Highlighting in App

Hello, I just updated the App Version from 10.0.40 to 10.0.43

Now I‘ve got the problem that syntax highlighting is not working anymore. I am still able to create code blocks which are displayed on the note but the content isn‘t highlighted.

My note looks like this:

Text (normal codeblock)

<?php
public function doSomething(): string
{
    return “Hello World“;
}

Text

Has something changed or is there a bug?
On my MacBook its’s still working.

Thanks and best regards

This might be a bug and is not limited to iOS. Same thing happens on Android.

I believe this has to do with the new renderer. @laurent any idea what could be the culprit?

1 Like

So, you’re getting a blank space, right?

@tessus, i’m getting blank text in the preview on both my iPhone and galaxy with no syntax highlighting in edit mode

1 Like

First of all there was never syntax highlighting in edit mode.

I’m talking about the preview (default on mobile). The code is there but not highlighted. (As if you had used ```plaintext).

1 Like

Gotya. Thanks.

Here are some Screenshots. Maybe they See helpful:

2 Likes

@tessus and @laurent, maybe it’s a specific model or iOS version issue because I just got home from work, plugged in the codeblock lines on my desktop and it’s working as intended on my iPhone XR. I’m currently on iOS 13.3 too

I can confirm that syntax highlighting is broken in Joplin 1.0.316 on Android 10.

Desktop version 1.0.179 has no problems.

Please create a bug in GitHub if something doesn’t work, as forum topics aren’t tracked.

Just updated to the newest iOS Version and got still the same issue.

I will create a bug when I got home.

Edit: Just switched from darkmode to lightmode. This solved the problem for me.

1 Like

I created a bug in GitHub:

Seems that dark theme is broken on iOS, bith themes are broken on Android.

1 Like