No-break space becomes a regular space in Markdown editor

A weird thing happens when I type a no-break space (Ctrl + Shift + U and then 00a0) in Joplin's Markdown editor. It simply becomes a regular space. If I type the character somewhere else and paste it into Joplin, the no-break space is preserved.

I could not reproduce the issue on Windows and on a live image of Fedora 38 KDE (using the same Joplin version stated below).

Steps to reproduce

  1. Type a no-break space between two characters in Joplin's Markdown editor. E.g.: 32 GT/s
  2. Shrink window: GT/s will break into a new line
  3. Copy text from Joplin and paste it into a tool that can identify invisible Unicode characters
  4. It will show that the "no-break space" you typed is actually a regular space
  5. Type the same sentence in a different text editor, copy it and paste it into Joplin
  6. Repeat steps 2 and 3
  7. You will see that the no-break space is preserved

Short video showing the issue:

Operating System
Pop!_OS 22.04 LTS
Kernel: 6.5.6-76060506-generic

Joplin (and Outline plugin) version
Joplin 2.12.19 (prod, linux) — installed using installation script (
Revision: 7081046
Outline: 1.5.10

I'd appreciate it if you could look into this and let me know if it's a problem with my system or a bug in Joplin. Please let me know if you need additional information.

If you prefer that I create a GitHub issue, please let me know and I will do so. Thank you!

Does this also happen in the note title input (or just the markdown editor)?

It's just the Markdown editor. I've just tried typing it in the note title input and the no-break space does not become a regular space.

Hi all,
I tried and it works for me

Joplin 2.12.19 (prod, linux), Debian Bullseye, Xfce
Révision : 7081046
Enhancement: 1.2.1
Favorites: 1.3.0
Quick Links: 1.2.4
Resource Search Plugin: 0.1.2
Rich Markdown: 0.13.3
Search & Replace: 2.2.0
Templates: 2.4.0

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.