BUG: \xa0 - non breaking spaces in webclippings

Joplin 1.0.216 (prod, darwin)

Client ID: c49067c17dd94e6dab4bf2f4a702df21
Sync Version: 1
Profile Version: 29

Revision: 4eb680d (master)

I’ve noticed that in my web clippings, I’m getting no-break space characters in the output. This seems like a bug to me since this is an undesired character to see.

An example website I clipped: https://olywip.org/podesta-email-reveals-democratic-pied-piper-strategy-backfired/

And what it looks like in the editor below. Note the red with a white dot in the middle. Those are the no-break characters.

Still happening in

Joplin 1.0.218 (prod, darwin)

Client ID: c49067c17dd94e6dab4bf2f4a702df21
Sync Version: 1
Profile Version: 30
Keychain Supported: Yes

Revision: 5be8c2c (master)

Anyone know what causes this? Is there a fix? It’s happening on a lot of pages for me. @laurent ? @tessus ?

First of all, a non-breaking space is still a space. I suggest to configure the editor to show it as a space. It’s the same as setting your editor to show whitespace characters and then complain about it.

However, in this case it might be a bug. Laurent added a commit that should fix this:

P.S.: Please mention the clipper version for clipper issues. The desktop app version might not help.

Joplin Web Clipper: 1.0.19

How can I configure the editor not to show them ? This is the internal editor to joplin that's showing it.

Ah, that's a recent commit indeed :slight_smile: thanks.

Which editor is it?

"This is the internal editor to joplin" IOW, the editor that comes with joplin

Code Mirrow, Ace Editor, or WYSIWYG ???

Joplin Web Clipper: 1.0.19

This one is 7 months old. The latest version is 1.0.25

It’s the latest version listed here https://chrome.google.com/webstore/detail/joplin-web-clipper/alofnhikmmkdbbbgpnglcpdollgjjfek?hl=en-GB

I don’t know? I think it’s Ace Editor? is that the default editor ? If you do a fresh install of joplin, and just start writing a note. That editor. In vim mode. (but I tried the other modes too and it’s the same)

Normally there’s some styling to disable highlighting of non breaking spaces but perhaps it doesn’t work with this theme. How does it work with with Code Mirror? You can select it in config > Note

Yes. It seems it's a theme issue. In my theme it looks like this:

There should be a way to tweak that in userchrome.css.

I think i also see it on notes imported from evernote, so I don’t think it’s the clipper. so yeah, maybe it’s a theme thing. I thought maybe those are usually converted, but I guess not

They are sometimes needed for example for indentation, so they indeed aren’t automatically converted by the clipper.