New user - sync on iOS not working

Unable to sync on iPhone running latest iOS (14.2) and using OneDrive.

All seems fine on PC but sync on iPhone seems to be repeating counts (not 100% sure of this) on items to sync. Have tried uninstalling/reinstalling the app but makes no difference. As there's no way to enable background app refresh for Joplin, not sure how I can fix this.

Entire notebooks do not appear which are there on the Windows app. Was hoping this was going to be an Evernote replacement, but starting to wonder now!

Has the syncroinization ever been completed (iOS: Configuration->SYNC STATUS, PC: Help->Syncronisation Status)?
Joplin has no background sync, so if the app is not running in the foreground it will not be synchronized!

Not completed as far as I can see. I keep going back to the app (for more than 1 day now) but it never completes and may even re-start. The phone will lock eventually and I don’t keep the screen unlocked for more than a few minutes at the time. It seems an odd requirement to have the screen ‘on’ for hours (if that’s what’s necessary)?

While you are waiting for iOS users response I can confirm that it is necessary on Android. It took two nights for me.

Thanks for letting me know!

  • quick update - it's working now I've set the screen lock timeout to 'never'. Thanks again.

My OneDrive sync with iOS was working fine until today, when I'm receiving a "Invalid API or Resource" error on my Mac and what appears to be a never-ending series of "Fetched items" messages on iOS.

I haven't done the obvious "restart" or export everything and start over, but posting this in case others are having similar difficulty.

Having this exact problem.

My sync target is OneDrive.

Endpoints are Apple devices.

  • Mac : Catalina (10.15.7) running Joplin app 1.4.19
  • iPhone : iOS 13.3.1 running 10.4.1

Both go into endless sync mode.

iPhone seems to increment number of items to fetch, fetches those, then bumps up. (i.e, fetching "x of 32", then as x gets close to 32, it's "x of 48", then "x of 64", etc)

Mac shows "Last error: Error: Invalid API or resource"

image

Worked flawlessly until about 2 or 3 hours ago.


Update 1: I tried removing Joplin from phone, rebooting phone, and reinstalling Joplin to phone. Phone starts sync but goes into a never-ending series of "Fetched items" messages as described above. This is new behavior and I've been using Joplin for . . . awhile. Back in the dark times before vim support was in the Mac client. :slight_smile:


Update 2: prior to this problem Joplin has worked flawlessly on phone and laptop with sync target as OneDrive.

1 Like

I have exactly the same problem on my iPhone since yesterday. Today it stopped working.

The error message on my phone is: Invalid API or resource

I cannot find an option to export my sync log on iOS. I could send you screenshots of the log instead.

Update: After getting some issues with encryption, and having only just imported data from Evernote, I decided to delete Joplin and start again. Uninstall did not remove everything, so a search/delete of C drive for 'Joplin' was required.

Was looking promising, but I've imported one notebook to a 'clean and empty' Joplin install but now getting this error: "Last error: Error: Item does not exist".

Seriously thinking that maybe Evernote wasn't so bad after all!!

I did some testing.

  1. wiped my OneDrive sync target (the Joplin folder in /Apps in OneDrive)
  2. wiped Joplin desktop app's config directory (I'm on Mac so ~/.config/joplin-desktop)
  3. launched Joplin desktop
  4. the default 5 "welcome" notes appear. I delete notes 1-4.
  5. configure sync target to OneDrive
  6. sync seems to work once or twice but after one or two syncs will return nothing but Error: Invalid API or resource

Attached is a log from when I click Synchronize. (the '...' are hex / GUID that I can't unpack, not sure if the bearer tokens are one use or long lived)

prob.txt (3.8 KB)

Wondering if there has been a new build of Joplin recently? I'm willing to invest a bit more time but with the Evernote v10 problems seemingly getting resolved, I'm not sure how much more effort it's worth to get Joplin working properly. A shame as it's a better product in some way (encryption) but not in others (search inside attachments such as images).

Now also have everything synced but getting the same "Invalid API or resource" error. :frowning:

I wonder if this could be a problem with Onedrive, not Joplin ?
All the posts above mention the same target : Onedrive.

It just happened to me too (Windows 10 PC, Joplin 1.4.19 portable), trying to sync to Onedrive :
=> "Last error: Error: Invalid API or resource".

I also run another instance of Joplin portable (for testing), synchronized with a Nextcloud server, and there, I have no problem.

Absent a way to test, this is my theory too.

I didn't change anything on my end. No updates to laptop, or to Joplin. Looking at the log the Invalid API errors started on 7 Dec.

OneDrive API looks reasonably static, but OneDrive is part of Microsoft Graph which updated their Change Log on . . . 7 Dec. https://docs.microsoft.com/en-us/graph/changelog#december-2020

But reading through the Change Log I quickly realize I'm out of my area of expertise. :frowning:

Just ran a test - swapped my sync to DropBox and it works without error. So, it is OneDrive related.

Only problem is I don't want to use DropBox, as I have a 1TB OneDrive allowance and don't want to pay for DropBox.

Any way to report this as a bug and hopefully get a fix?

It is a bug from Microsoft. It is already reported https://github.com/OneDrive/onedrive-api-docs/issues/1408. But who knows when Microsoft fix this.

Thinking out loud here.

tl;dr: the following is probably a non-solution.

For desktop installs, I could point Joplin at a local proxy and intercept the broken response from MSFT, transform as follows:

received from MSFT: drives('66d53be8a5056eca')
transformed: drives/66d53be8a5056eca

Doesn't seem too tricky. But this workaround doesn't offer any assistance for mobile.

Rats.

FWIW my OneDrive sync problems seem to have gone away without me doing anything. All's well with Joplin now.