Homepage    |    GitHub    |    API    |    Wiki    |    FAQ

New install - and my File menu contains only "Exit"

Downloaded Joplin-Setup-1.5.12.exe (188,572 KB) to my Windows 10 Downloads folder.
Double clicked on it and eventually got the screen saying Joplin was installed.

I double-clicked on Joplin from my Start menu and what appeared to be the Joplin opening screen appeared. I clicked on "File" and the only item appearing in the drop-down menu was "Exit". The Edit, View and Windows menu items each had sub-headings to select. The "Help" menu, when clicked, read "empty".

How do I create a new item in Joplin? I was expecting to see something like "New" in the "File" menu, but no such luck! Nor are there any icons which might help.

What do I do next?

Thanks.

I'll assume that is simply a typo for 2.5.12, otherwise you are on a very old release.

It sounds like its just the default electron window without any Joplin stuff loaded. What happens if you run it as administrator?

You are correct: 2, not 1 - it was a typo.

I will try running it as admin shortly and reply further then.

Thanks.

John S. Kennedy

I ran it as administrator: nothing different. The only item under the "File" menu heading is "Exit".

What should I try next?

Thanks.

There must be something wrong with my download.

Clicking on the X at the top right corner of the screen did not shut Joplin down.

Clicking on the Exit item under the File menu did nothing either.

So I went to the Control Panel and discovered I somehow had 4 instances of Joplin running. The only way to shut them down was to "End Task".

It took six tries this afternoon to download the Joplin install file. Grant you, it's an old computer. I thought perhaps on a cold, snowy Sunday afternoon that the local internet connection might be slow. I will try again tomorrow, once kids are in school, and see what happens.

Weird!!

Monday morning: I just uninstalled Joplin (Version 2.5.12), then tried downloading it from a different source (SourceForge). It took a few tries to download the setup file, but ultimately, the result was the same as before. Joplin screen shows up, but under the File menu, only the option of "Exit" appears.

Clicking on "Exit" does nothing - no exit, nothing changes.

Unless someone has a bright idea, I guess Joplin is out and Obsidian is in.

Thanks for any help.

I wonder if you are able to install the last 2.4 version as this was the last one to use the older electron framework.

I will let you know shortly. Thanks for the tip.

I found Version 2.4.12.exe online. The download and installation went notably more quickly than with Version 2.5.12.

This time, the Help menu had several topics below "Help". Unfortunately, the File tap had only the word "Exit" beneath it.

No more luck, I guess!

Under the Help menu, is there a Toggle Development Tools items? If so could you open it and see if there's any error or warning in the console?

https://joplinapp.org/debugging/#desktop-application

No such luck, I'm afraid.

I wonder if my slow Windows 10 machine is simply too old to be up to running Joplin. I't got to be about 10 years old now....

It should be fine. Could you try to get the console to open as described in my debugging link above?

Sorry: you are talking to a complete Newbie here. I didn't realise that such was the purpose of the link. I will dig around and try to find the console.

The only topics listed under the Help menu on my screen are: Learn More; Documentation; Community Discussions and Search Issues.

No sign of "Toggle Development Tools", "Open Profile Directory" or the word "console".

Something is certainly amiss and I haven't a clue what!

Is there more information I could provide to help with a diagnosis?

I'm not sure if this will work in the current state, but try to enable the debug mode:
Create in the folder %userprofile%\.config\joplin-desktop a file flags.txt, with the following content --open-dev-tools --debug --log-level debug and share the createt log.txt from the same folder.