More 1.4 Oddities

As a follow-up to Right-Click to Paste when Creating a Hyperlink Not Working (I'll call that issue 1) I've discovered a couple of other odd items...

Issue 2
RE: Spell check in the markdown editor -- it doesn't like "cleartext". For other techie-words it didn't like, I was able to right-click and add to the custom dictionary. But with this word, I'm getting no right-click option. I've closed and reopened Joplin a couple of times with no change.
image

It seems to be specific words... I've deleted and retyped them, intentionally misspelled words and confirmed I get the 'add to dictionary' menu for them, but these specific words just refuse to play. This time it's "SecLists"
image

Issue 3
RE: Bold. (and Italic) I highlight text with my keyboard, then hit ctrl-b to make it bold, and the text just flashes - it doesn't apply the markdown to make it bold. I'm able to click the B icon at the top to make it bold, but I prefer to work just with the keyboard as much as possible. (I confirmed CTRL-B is still defined as bold under the keyboard shortcuts options.)

UPDATE: I confirmed that when I disable spell check in the markdown editor, I'm able to ctrl-b for bold, ctrl-i for italic, etc. again.

Issue 4
RE: END key. While maneuvering through text I often use the home key to go to the beginning of the line, and end to go to the end of the line. end doesn't seem to be working a lot of the time; it reminds me of the previous editor... did something change with the editor? (I'll track down release notes...)

I'll update if I run across anything else...

Thanks!!

Issue 1: I can confirm this is happening

Issue 2: I can't confirm this on my computer, I've tried with the same words and it works fine

Issue 3: Should be fixed soonish

Issue 4: The end key is working fine for me, with one hiccup when spellchecking is enabled. Instead of the cursor going to the end of the current line, it ends up going to the start of the next line. Which if you think about it is basically the end of the current line :slight_smile: . I think this can probably be fixed by remapping the end key to go to the end of the line and step back by 1 character. Let's see if other people experience the same issue first.

1 Like

Thank you @CalebJohn!

I got frustrated enough that I finally disabled spell checker in markdown a couple days ago.

Yet I still have trouble with right-clicking occasionally. This morning, for instance, I've closed and reopend Joplin several times, yet I cannot get the right-click menu on a note to come up so I can copy a link.

1 Like

Seems like the same issue: https://github.com/laurent22/joplin/issues/4201

1 Like

Can you elaborate on which points you found frustrating?

see thread above lol :wink:

I'm also experiencing some oddities with 1.4

I enabled the (experimental) spell checker in the markdown editor using vim mode. Now the caret in empty lines is not visible anymore. Checked that it is not a CSS issue and it comes back when I disable the spell checking.

1 Like

You can track that but here it's an upstream issue with the editor component we use. Unfortunately we knew there was going to be some upstream issues, which is why the setting is hidden and includes a warning.

I'll be checking the upstream status occasionally so hopefully an update comes in the near future and we get this fixed.

2 Likes

yeah, that's what I thought... Thanks anyway for all your efforts! Really appreciate Joplin and the community. :slight_smile:

1 Like