Markdown files in Joplin AppImage directory?

I had a fairly awkward setup for syncing two Joplins, one at work, one at home - via an intermediary share on my cloud storage pCloud.

Home Joplin ~/.config/joplin-desktop
Work Joplin ~/.config/joplin-desktop

both would be synced with pCloud/Joplin share independently. Since I was only ever using one of them at any one time, it worked relatively well.

Since 1.0.117 AppImage, I’ve had all sorts of trouble with the setup, often seeing one or other of the Joplin stores empty.

I’m trying to set it back up from scratch (importing from a .jex file backup), running the AppImage from a bash script file - calling it with the “–profile ~/Tools/Joplin/JoplinProfile” option .

So I’ve just run Joplin AppImage from the script from ~/Tools/Joplin directory (where I keep the AppImage files). I copied and renamed “Joplin-1.0.117-x86_64.AppImage” to just “Joplin.AppImage”.

Clean Joplin run fine, then I imported from a JEX file and now I have all the data in Joplin but the following has happened.

All the Markdown files are in ~/Tools/Joplin directory where the AppImage file is.

There are .resource and .sync directories under that one.

And in the JoplinProfile directory there are:

resources and tmp directories
log.txt, log-clipper.txt, log-database.txt files
database.sqlite file

~/Tools/Joplin/JoplinProfile/resources directory seems to hold 12815 image files (gifs, pngs, svgs)


~/Tools/Joplin/.resource seems to hold 12815 same image files, without file extensions.

I’m on MX Linux 18.

None of this is hooked into the pCloud sync system yet, because I don’t understand the resource file placement.

Presumably this is an issue with a large database that has gone through many version changes of Joplin, and the last move to 117 has caused some problems?

Any advice or help, in getting Joplin back to a state where I can run it locally would be very much appreciated.

Is it ignoring the --profile location option?
Why do I have two copies of the image resources from a JEX import?

My original dataset come from an extensive Evernote export on a much earlier version of Joplin, and I’ve been a big fan of it ever since, but now my data is a bit all over the place… perhaps it is too big a set?

Total folders: 57
Total notes: 2625
Total resources: 12815

I suppose I could cut it all up, and trim out the legacy stuff I have from years back, to try and make the data store nimbler, but it would be useful to understand the directories and relationships to settings/resources before I start a major cull.

Again, any help gratefully received.



Answering myself here, but I think I’ve worked out why these md files are appearing in the AppImage directory. It’s obvious really, my Syncronization was set to “File System”, but disabled.

However, if Sync was run for any reason, a File System target would result in the .md files being created in the same directory as the Joplin AppImage.

I think it is a result of my misunderstanding how Joplin stores its data (in the sqllite db) and how it syncs its data with the sync target.