Known bug (caret jumps to top of editor)?

Joplin 2.9.12 (prod, win32)
Windows 11 Home
No plugins installed

Sometimes when editing a note in the WYSIWYG editor, usually after pressing Enter to start a new line, the caret jumps to the very top of the editor and insertion happens there. So far I've not been able to predict when it'll happen nor see any pattern, but when it does I have to edit the Markdown directly in order to get my entries in the right place.

I previously had an alternate editor (Rich Markdown, maybe?) and removed it thinking it was the culprit but it made no difference. This has also happened on the last couple of Joplin versions I've used, as well.

My apologies if I'm missing something but I don't have a huge history with Joplin. I've not looked into filing a bug report yet in case this is already a known issue.


1 Like

I've had a similar issue with Grammarly on Android. Are you using Grammarly or some similar text input tool?

Does the issue happen in other programs?

No and no. Just plain vanilla Joplin.


I have no idea if it's related because I've seen it only once so far, but the last time it happened was while Jopin was syncing. Related? Dunno.

1 Like

I see the same problem - sometimes when editing I find the caret has jumped to the top unexpectedly. I also haven't been able to pinpoint when or why it happens.

Joplin 2.9.12 (prod, win32), Windows 10, I do have some plugins.

I've not nailed it yet, but it seems that once it starts happening it'll be persistent until something changes to "reset" <whatever>. I've tried using the source editor instead of WYSIWYG when it happens and so far that's gotten around it for the moment, but no idea if it's a persistent workaround.

I've also seen other bugs - I'll have a series of, say, five bullet points. I'll copy some text (from elsewhere in the document), highlight one of the existing points to replace it, paste and *boom* ... one or more of the other non-selected bullets (text and all) are gone.

Or I'll select some text and enable bullets - And suddenly virtually everything in the document is bulleted!

Good thing at least that Undo works! LOL

I realize the WYSIWYG editor is just twiddling the Markdown under it, but apparently it's not doing it 100% accurately. I like Joplin, but these editor bugs are startling and somewhat annoying to say the least. The trouble is, they're so intermittent that I can't reproduce them at will.

I've not looked into it at all, but I wonder if there are other (better) editor plugins... or whether whatever's happening is outside the actual editor (in which case it would make no difference).


For the bullet issues, I consider it as the editor not quite having full support of bullets, so I take any bullet editing as experimental.

The caret issue currently seems unavoidable and happens randomly during basic edit work. Would be interesting to see if it's common to other people and perhaps someone found more info.


The rich text editor is based on TinyMCE, which is an HTML editor. Joplin converts to/from HTML when loading/saving data from the editor.

Joplin currently uses an outdated version of TinyMCE. It's possible that these are bugs in that version of TinyMCE. It's also possible that the bug is in how Joplin is using TinyMCE.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.