Joplin won't start anymore (portable version)

JOPLIN version : last portable version (available on the home website)
OS : Windows 10 with all update available (last update : KB4517389)


Recently i have a problem to launch JOPLIN portable version …
When i click on JOPLIN an hourglass appears as if it was about to launch itself but in the end nothing (no error mesage or something else). However, the software was working yesterday.

When i click on it i can see the processus during for a few seconds in the task manager but then disappears.

I try to exclude JOPLIN from my anti-virus (avast) and execute as administrator but it didn’t change anything.
I also ran some tests with malwarebyte, adwcleaner and ZHPcleaner but nothing again.

I also try to launch JOPLIN with this version but same.

Can you help me please ?

version please

1.0.135 but i also test with 1.0.140

I don’t get why your are digging up versions from 7 months ago? Don’t know if the latest version would work better but how about giving it a try?

Because i downloaded portable version from this page and I figured it was a recent version.

So i tried with the latest version i found : 1.0.169 and same results. Portable version won't start :frowning:

Please provide a debug log

Sorry i don’t understand how to do with the portable version…

That’s what I did :

  • Launch CMD
  • Go to the directory of “joplinPortable.exe”
  • then typed: “JoplinPortable.exe --log-level debug”

It doesn’t indicate any errors but i don’t know if it’s ok and if it is, then i don’t know where is the log file.

Tell me if I did something wrong.

Desktop application:link:

  • Add a file named "flags.txt" in the config directory (should be ~/.config/joplin-desktop or c:\Users\YOUR_NAME\.config\joplin-desktop ) with the following content: --open-dev-tools --log-level debug
  • Restart the application
  • The development tools should now be opened. Click the "Console" tab
  • Now repeat the action that was causing problem. The console might output warnings or errors - please add them to the GitHub issue. Also open log.txt in the config folder and if there is any error or warning, please also add them to the issue.

In your case, flags.txt should go in the JoplinProfile directory.

So i put “flags.txt” in “JoplinProfile” (content : --open-dev-tools --log-level debug)
Then I execute “JoplinPortable.exe” (which is in the same directory as “JoplinProfile” ), but nothing happens.

However, I already had a log file in “JoplinProfile” but i guess it is not relevant.

(content log.txt)

2019-10-13 03:34:56: “RevisionService::maintenance: Done in 1002ms”
2019-10-13 03:36:00: “Running background sync on timer…”
2019-10-13 03:36:00: “Scheduling sync operation…”
2019-10-13 03:36:00: “Preparing scheduled sync”
2019-10-13 03:36:00: “Starting scheduled sync”
2019-10-13 03:36:03: “TaskQueue.stop: syncDownload: waiting for tasks to complete: 0”
2019-10-13 03:36:03: “TaskQueue.stop: syncDownload: Done, waited for 0”
2019-10-13 03:36:04: "Operations completed: "
2019-10-13 03:36:04: “fetchingTotal: -”
2019-10-13 03:36:04: “Total folders: 19”
2019-10-13 03:36:04: “Total notes: 122”
2019-10-13 03:36:04: “Total resources: 19”
2019-10-13 03:41:04: “Running background sync on timer…”
2019-10-13 03:41:04: “Scheduling sync operation…”
2019-10-13 03:41:04: “Preparing scheduled sync”
2019-10-13 03:41:04: “Starting scheduled sync”
2019-10-13 03:41:07: “TaskQueue.stop: syncDownload: waiting for tasks to complete: 0”
2019-10-13 03:41:07: “TaskQueue.stop: syncDownload: Done, waited for 0”
2019-10-13 03:41:08: "Operations completed: "
2019-10-13 03:41:08: “fetchingTotal: -”
2019-10-13 03:41:08: “Total folders: 19”
2019-10-13 03:41:08: “Total notes: 122”
2019-10-13 03:41:08: “Total resources: 19”
2019-10-13 03:44:55: “RevisionService::maintenance: Starting…”
2019-10-13 03:44:55: “RevisionService::maintenance: Service is enabled”
2019-10-13 03:44:56: “RevisionService::collectRevisions: Created revisions for 0 notes”
2019-10-13 03:44:56: “RevisionService::maintenance: Done in 1027ms”
2019-10-13 03:46:08: “Running background sync on timer…”
2019-10-13 03:46:08: “Scheduling sync operation…”
2019-10-13 03:46:08: “Preparing scheduled sync”
2019-10-13 03:46:08: “Starting scheduled sync”
2019-10-13 03:46:10: “TaskQueue.stop: syncDownload: waiting for tasks to complete: 0”
2019-10-13 03:46:10: “TaskQueue.stop: syncDownload: Done, waited for 0”
2019-10-13 03:46:11: "Operations completed: "
2019-10-13 03:46:11: “fetchingTotal: -”
2019-10-13 03:46:11: “Total folders: 19”
2019-10-13 03:46:11: “Total notes: 122”
2019-10-13 03:46:11: “Total resources: 19”

Could you try to run this? JoplinPortable.exe --open-dev-tools --log-level debug

Normally that should open the console and there might be an error message in there.

Yes so

  • CMD as administrator
  • cd [path_to_JoplinPortable.exe]
  • JoplinPortable.exe --open-dev-tools --log-level debug

And nothing happens, not even a error message.

I guess the problem comes from my computer but it was working yestarday :frowning:

Since it’s the portable app, I’d just put it on a USB key and try it on a different computer, just to be sure.

So i tested it in another computer (Windows 10 with lastest update).
For the test i downloaded JoplinPortable from this (for "clean" installation) --> Releases · laurent22/joplin · GitHub)

When i run the application the anti-virus (avast) says that the application may be "dangerous" and to be sure avast cyberCapture will test the application in "avast lab" ...

So after few seconds joplins starts correctly.

So after that i deleted "joplinProfile" created by joplinPortable.exe
I moved MY "joplinProfile", where i have all my ressources, in the same directory and it works ....

I copy both (".exe" and "profile"), in my external HDD an try to execute from this support....
It failed (nothing happens) ... i still tried to copy that in my other computer (problem computer), and same ... not working and nothing happens :frowning:

So it's my computer but i really don't understand why.
Does Joplin have any conflicts with other software ?

So i guess that is an infection … from where i don’t know … I haven’t done anything since yesterday on my computer …

I’ll try to fix it first!

Thanks for your time.

So I’m still continuing the anti-virus analysis but i don’t think its the problem.

So after the anti-virus scan: no changes and no problems detected.

So I restored my PC at an earlier date: 3 days ago (11/10) but the problem persists even though the software was running on 13/10.

My problem is still there but until I find out how to fix it I installed the “.exe” version and it works for this one.

Good finally the software works again…
I don’t know exactly what made it work, but here are the actions I did:

Update of drivers via the device manager + DriversCloud software.
Scanning of drivers with MSI Live Update software. The software found two other drivers that were not up to date.

I also did a computer cleaning with CCleaner by cleaning “old prefectch data”.

Thank you for your help!

1 Like