Joplin Termin token deleted?


I'm running Joplin Terminal (joplin 1.8.1 (prod)) on a raspian distribution (debian 10).
I installed with the recommended method (npm install)
I access to Joplin through it's API.
But I didn't find any way to set the token: I write it myself, but each time joplin is used, the token is delete.

A detailed step by step:

  • I check there is no token with sqlite3 ~/.config/joplin/database.sqlite "select value from settings where key = 'api.token'"
  • I write a token with sqlite3 ~/.config/joplin/database.sqlite "INSERT INTO settings ('key', 'value') VALUES('api.token', '1234567890987654321')"
  • I start joplin server: joplin server start
  • I can access the API with the entered token 1234567890987654321
  • But each time I use joplin command, (for instance joplin sync), the token is deleted from database.sqlite, so next time I'll start the server, I must enter again the token before.

I expect the reason is because I don't enable the API in the standard way... so joplin "doesn't know" it's started, and it deletes the token.

My question: what is the recommended way to enable clipper service with Terminal application? So that the token remains in the database.

Thanks in advance for help.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.