Home / GitHub Page

Joplin on pinebook pro

Been using joplin for some time now and very happy with it. This week i received a pinebook pro (linux debian laptop with armhf). So far it seems like a perfect tool for work. But for this i need joplin :wink:

the appimage does not work for armhf so i was wondering if there is something i can do in order to get acces to joplin on a armhf ? if not, is there a option that in the future there also will be an armhf

2 Likes

I don’t expect official support for ARM to ever happen, but you should be able to build it manually. See electron-builder doc: https://www.electron.build/cli.html#targetconfiguration

I have ordered my Pinebook Pro a few days ago and would love to see this work on it.

You indicated it could be built manually; is this a process that could be done with very limited knowledge or will that be difficult?

In also looking into that…dont have any expieriance but will try. I Will let You know if it works

1 Like

I’ve also ordered a Pinebook Pro also and I’d like to use Joplin with it.

It’s not clear to me from the question whether it pertains to both the terminal and desktop versions of Joplin.

Might the terminal version of it work on ARM even if the desktop version does not?

I run joplin on a pinebook pro with Manjaro ARM.

I used this aur package: https://aur.archlinux.org/packages/joplin/ .
You need to changethe PKGBUILD file a little.

  1. yay -G joplin
  2. cd joplin
  3. vim PKGBUILD
    3.1 change arch=(“x86_64” “i686”) to arch=(“x86_64” “i686” “aarch64”)
    3.2 change line 71. /ElectronClient/app/dist/linux-unpacked/"* to /ElectronClient/app/dist/linux-arm64-unpacked/"*
  4. makepkg -si
  5. wait :smiley:
5 Likes

That’s great!
I will be receiving my Pinebook Pro in the coming weeks.
Now I’m not so familiar with the package building. What if a new version of Joplin comes out; how would to upgrade it on your system?
Thanks.

you sir are amazing! :wink: took me some time as it did not work on the sd version of manjaro. Now ive got manjaro flashed it worked like a charm…so so happy!!

Anyone get this working on the stock Debian image? I was running Manjaro but went back to the stock image for awhile. I tried to use the instructions from the Manjaro post but that did not work. Not asking for someone to do this for me just point me in the right direction. Total Noob here.
Thanks in advance!

What version are you running? If it’s the latest, you should be able to pass —no-sandbox to your executable to get it up and running.

just repeat in install proces…updating wont do

1 Like

I was able to successfully install it using the instructions from klei on a Manjaro install, but using the GUI. I’m not that handy with the terminal. I did want to try the new Manjaro KDE 20.2, so I ended up reinstalling. Joplin also moved to 1.0.193. I am getting an error using the same steps. I found this message at the end before it says it says failure occured in the build:

[16:09:44] Finished ‘electronRebuild’ after 3.41 s
npm WARN ajv-keywords@3.4.1 requires a peer of ajv@^6.9.1 but none is installed. You must install peer dependencies yourself.
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: 7zip-bin-win@2.2.0 (node_modules/7zip-bin-win):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for 7zip-bin-win@2.2.0: wanted {“os”:“win32”,“arch”:“any”} (current: {“os”:“linux”,“arch”:“arm64”})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: 7zip-bin-mac@1.0.1 (node_modules/7zip-bin-mac):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for 7zip-bin-mac@1.0.1: wanted {“os”:“darwin”,“arch”:“any”} (current: {“os”:“linux”,“arch”:“arm64”})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.11 (node_modules/glob-watcher/node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.11: wanted {“os”:“darwin”,“arch”:“any”} (current: {“os”:“linux”,“arch”:“arm64”})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules/babel-cli/node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {“os”:“darwin”,“arch”:“any”} (current: {“os”:“linux”,“arch”:“arm64”})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.0 (node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.0: wanted {“os”:“darwin”,“arch”:“any”} (current: {“os”:“linux”,“arch”:“arm64”})

Any ideas on what else needs to be installed? I’m not that good at reading, this but from what I can tell there is a missing dependency preventing the install from completing. If anyone can point me to a possible solution, that would be much appreciated. This is a really great app and I miss it when I am on the PBP.

None of these are errors, just warnings, so if the error must be somewhere else.

1 Like

Thanks, laurent. Not just for the reply, but for making this awesome piece of software. I’ll keep digging and I’ll share anything i learn.

I am happy to report I got it to work. I found a discussion the in the AUR and decided to give it a try. I installed yarn before I started the install. I used Pamac (the GUI software tool) and edited the pkgbuild using the changes recommended from klei’s post. I hit install, waited, then yarn kicked in and installed some other packages. This time the install completed! I am syncing it right now :smiley: Posting this and hope it helps anybody else looking to install Joplin on the PBP.

Hi everybody.

i really like joplin and i just begin to work with arm64 machines. Of course i want to use the great joplinapp on these machines too:)

I know, that there is no official arm-team for joplin yet. But with more and more people using raspi’s and pinebooks, chromebooks and so on, i thought, maybe there is a change, that some developers start to work an official “joplin-arm”.
How is the chance for that happening?

There is the x86 version and there are android and ios version (arm machines). So is there a realistic chance of making joplin arm for desktop?
So that people can install and update joplin as easy as with the install-script.
That would be awesome.

Best greetings
I look forward, to hear from you:)