Joplin is converts non-standard spaces to regular spaces... could it please not

I have use cases not worth getting into for using the non-standard space characters, and I need them preserved in my notes. However, when I try to insert one through a macro or paste them via the clipboard, they are converted into normal spaces.

I don’t understand why this behavior even exists, and I would really like to disable it.

Does it work if you use an external editor?