Joplin in NAS Synology (webDAV)

If you exclusively use Joplin at home, really doesn't matter whether or not you use HTTP or https.

I use http because that's all my NAS server supports with Joplin server and I pair that with a free peer-to-peer VPN called tailscale. End to end encryption and access to your network attached storage server from anywhere on the internet so if you are out with your phone somewhere you can still synchronize from your phone to your server even if you're not home and you don't need to open any ports on your router and the software is straightforward to set up. It only took me minutes to configure three PCS and my NAS server and my phone.

1 Like

Is there a performance difference between http and https for Joplin sync?

I doubt it. I'm guessing that since http does not do encryption, it might be slightly faster but i doubt there is a way to measure it.

I use regular http and combine that with tailscale VPN for when I am away from home and want end to end encryption.

1 Like

Here we go, the first sync is in progress :slight_smile:
image

Is it normal that there are already deleted remote objects? (762)

EDIT: after some hours, I now have a lower number, is it normal?
image

Also, when creating the shared folder on my NAS, I left the trash active (default):
image

image

Is there any point and/or could it cause a problem?

I put a / at the end of the path, but on the Joplin doc for Nextcloud, it is indicated without:
https://example.com/nextcloud/remote.php/webdav/Joplin
Does it matter?

1 Like

HarSel

GREAT! After reading and trying many other tips to get Joplin syncing to Synology WebDAV, your tip is the only one that worked. It was blazingly fast compared to Dropbox. I use it only in my home network.

Hi,

That's it, my synchronization with the Synology WebDAV server is complete on my two Windows PCs.

So I tried to start sync on my Android device and I indicated my ddns address like https://myname.synology.me:5006/joplin/ but after several hours nothing seems to have progressed: 6/6 sync objects/total. While I actually have 149200 objects in total.

I'm connected to my local WiFi, I read that could be the problem, what do you think?
I'm going to try with my local fixed IP in http... EDIT: same issue. I created a dedicated topic here:

Thanks

Hi everyone,

I'm new to Joplin, trying to sync to my NAS via webDAV.
It works well for my two laptops (https:xxx.xxx.xx.xx:5006/joplin and webdav credentials), but not for my iPhone and iPad, although I use exactly the same configuration.
However, it only works on laptops when I tell Joplin to ignore TLS certificate errors, and this option is not available on mobile:
Could that be the cause of the issue? Is there anything I should try (apart from trying to sort the certificate issue^^?)

Thanks in advance for your answers.

OK so I found the mistake, i was using the IP address instead of the URL, thus I had a certificate mismatch error, which the desktop app can handle by choosing "ignore TLS certificate errors" in the advanced settings, but not the mobile app.
replacing [1xx.xxx.xx.xx:5006] by [....synology.me:5006] did the trick, and I can access the notes from outside too.

1 Like