Home / GitHub Page

Joplin in NAS Synology (webDAV)

Hello everybody,

I really want to conect Joplin to my synology NAS by webDAV.

I’m triying but not results. :weary:

Someone has it connected and can do a mini tutorial please.

Thank you very very (very)^99 much <3

I assume you installed the WebDAV server on the NAS?
https://www.synology.com/en-global/knowledgebase/DSM/tutorial/File_Sharing/How_to_access_files_on_Synology_NAS_with_WebDAV

What exactly did you try, what results did you get, and what didn’t work?

1 Like

TY for you time :smiley:

I paste the results:

And I have the WD activated:

I think there was a problem with custom ports. I’m not sure if this has been fixed already.

Apart from the current issue, it’s rather a bad idea to use an unencrypted channel. You have activated https on port 5006, so why don’t you use https instead?
Anyway, it’s still a non-standard port, so if the “custom port issue” hasn’t been resolved, switching to https won’t help either. It’s just safer as soon as you get it to work.

I also suggest to create a debug log to better handle the problem determination. Right now, we all do not know what the problem is.

Custom ports are almost certainly the problem, and sadly this is, in its current state, unfixable since the Synology WebDAV application will not allow you to configure it to use ports 80 / 443.

Frustrating :frowning: I realize this is an open source app, I’ll put in the feature request on the Synology side :slight_smile: They have the $$$ to fix this kind of problem :slight_smile:

@laurent is there a way we can support custom port? I remember it didn’t work at one point, when a web dav address like https://example.com:8213/dav/Joplin was specified. But IMO this should work.
If you point me to the right file, I can have a look at it.

Joplin uses whatever URL you specify. My guess would be that non-standard ports will work on desktop but not on mobile. If anything doesn’t work, we need to see the log.

I’ve been using WebDAV on Synology NAS for Joplin sync for a while now. The URL is https://*****.synology.me:5006/joplin/ on mobiles and http://[local IP address]:5005/joplin/on desktop.

1 Like

This helps me a lot. Silly question but is the ***** in https://*****.synology.me:5006/joplin/ stand for the quick connect address? Also how do you find your experience using WebDAV? TYIA!!!

Yes, that’s right.

webDAV on the Synology NAS works very well. I had problems with Dropbox and Onedrive, but the NAS is quite smooth.

I also set up NAT loopback on my router so that when I’m on the local network it’s not going out to the internet and then back when syncing.

1 Like

So if my quick connect is bob, then the address would be https://bob.synology.me:5006/joplin/ correct?
How do you get yours to work on the mobile Joplin app? Being trying for the last couple of days with port forwarding and all, just keep getting “network request failed”. Did you have to get any certificates for it work? Did you set up your router through synology external access? Sorry for all the questions. Can’t find a specific answer anywhere lol

Has been working great on desktop though lol. Was using Resilio sync before this so I was able to just enter the direct path for the folder I was using. http://[local IP address]:5005/homes/username/Joplin/

Thank you!!

Yes, that’s the format of the address I use. I’ve got a certificate from LetsEncrypt, which I think I needed for Joplin on IOS but not on Android. There was a useful video somewhere showing you how to apply and install the certificate. It gets renewed every 3 months.

Your desktop direct path is going to a folder under your username, which is under home. However, my webDAV folder, just called joplin, is top level, and I think that’s what your WebDAV URL would be looking for. You could maybe try https://bob.synology.me:5006/homes/[username]/joplin/, or move the sync folder to be at the top level.

Also, have you configured the WebDAV server on the Synology NAS?

As far as the desktop is concerned, I used to use the direct path but I read, on this forum I think, that maybe that’s not a good idea because if the network connection goes down Joplin can act as if the sync folder is empty and will start deleting your notes. So I changed the desktop to use WebDAV too.

1 Like

Hi I think there a bit of confusion here. It’s not the quick connect address from synology but the synology ddns you need I made this mistake last week

1 Like

@williwinkie it worked!! wow. It didn’t occurred to me that I actually needed to add the hostname to DDNS under Control Panel before using it!! It worked almost immediately! Thank you everyone for your help!!

@laurent is it possible to add Synology to the list of WebDAV synchonisation? This is a great solution in my honest opinion.

So just to recap, and anyone can correct me if I’m wrong; to get WebDAV synchronisation working on a synology NAS:
1-Create a Joplin shared folder at the highest level in File Station.
2-Download WebDAV server from the Package Center.
3-Enable HTTP/HTTPS.
4-Under External Access in Control Panel, select Add under DDNS to create a registered hostname.
5-Under Router Configuration, select Create to add port forwarding rules for the ports used in the WebDAV server application (the default 5005,5006 were used in this case).
6-Go to your Router and open the same ports. In my case, I have a Lynksis router and it was under Security->Apps and Gaming->Port Range Forwarding.
7-Go back to Router Configuration under External Access and test the connection. Should result in “ok” in the Connection Test Result column.
8-I would suggest manually backing up your notes to the Joplin folder and to another folder on your desktop or a drive in case synchronisation tries to delete your notes.
9-Under the Synchronisation section of Joplin:
-use http://[local IP address]:5005/joplin/ for the desktop version
-use https://*****.synology.me:5006/joplin/ for the mobile version. In this case, this address needs to be the same one you created in STEP 4.
10-Enter the login credentials under WebDAV username/password for your Synology NAS.
11-Select “Check synchronisation configuration”. Should result in “Success! Synchronisation configuration appears to be correct.”
12-Now you can select Synchonise in the main tab and you’re done!