Joplin extension on firefox 97 installed from snap

I've just noticed after recent update of firefox to 97 (snap by cannonical) that the extension is unable to contact web clipper service anymore.

Any hints what is going on? I suppose it's related to firefox snap packaging as I do not see any other reports here.

We didn't change the extension recently so it's a bug you should report to Mozilla.

It's obvious that mozilla won't fix this extension. It's really sad it stopped working, it was very useful.

Most likely it's some dumb rule that blocks local connections they've added recently, without caring if it's going to break something. Are there no settings you can tweak to allow these connections?

I found the same problem with my Firefox 98 installed without snap process. I do not know if we found the same issue, but I dealt with this difficulty, removing and installing again the Joplin extension in my updated Firefox version. Trying to check it if this resolve the issue.

Unable to reproduce it on Ubuntu 20.04

Joplin 2.7.14
Installed with the official script
and also tested with snap version

Firefox 98
Installed with snap.

Can you once check your firewall rules.

I have changed firefox from snap to .deb - uninstalled and installed extension - still the same result.

FF 97.0.1 and Joplin 2.7.14 Appimage do not go together - Error: could not connect to Joplin application.

Just to confirm. Did you enable the Web Clipper Service in the settings?

I was using it successfully for a year, it is a big lose to me.

$ lsof -i | grep 41184
@joplinap 4016942  ser  131u  IPv4 50998184      0t0  TCP localhost:41184 (LISTEN)

OK, I had to learn about extensions to be able to debug it.

It was pretty straightforward - I had to open special page about:debugging, find joplin extension and then click on the J button.

It shown me that connection to is overtaken by a proxy :slight_smile: So I manipulated proxy entries and allowed that port to work locally. Voila! I have the extension working back.

It's an amazing day today, I really missed Joplin for last few weeks!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.