Joplin exits early after choosing either configuration or synchronize

Operating system


Joplin version


What issue do you have?

I'm running Android 11 on a Lenovo M8 Tablet, last security update in Fall 2021. In order to expand storage space, I bought an 128 Mbyte micro-USB disk, and configured the tablet to use the disk as internal memory (not as portable storage).

I'm running Joplin 2.12.3, downloaded from the Play Store. I've modified the permissions, particularly the permission for "files and media" (However, only media shows up in the permissions.)

I can create a new notebook, add notes to it, and edit the notes. However, if I add a tag on that note, it's accepted, but it doesn't show up when clicking the Tag button in the sidebar.

If I click on either the Configuration button (or the Synchronize button) in the sidebar, the button dims, and after 4 seconds or so a message box appears that states "Joplin has stopped".

This doesn't happen on any of my other devices (Pixel 7, Pixel 3aXL, Samsung Tab A7 lite, two FireHD8+ Amazon tablets) where I run Joplin (nor is it a problem in the desktop application on Windows).

That is a tough nut, have you tried to completely uninstall and reinstall Joplin ?
I am running a similar config (Android12, microUSB as int.memory, Joplin version), and I cannot reproduce the problem. But that isn't really a surprise given your other devices listed.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.