iPad app hangs and is unresponsive

iPadOS: 14.0.1
6th gen device
Joplin: 10.2.1

Using Joplin on my iPad is essentially impossible. On my iPhone it works just fine though. I've removed and reinstalled it numerous times. The only configuration setting that has been altered is using Dropbox for synchronizing notebooks.

What happens is that once I go to any page, all menu items or icons basically act like they aren't being pressed or aren't registering. I can swipe up/down to scroll, but that's basically it. If I close out the app and open it, it lets me move to one other page and does the same thing. (over and over) It's strange. I don't have the problem with any other apps on the device.

If I don't configure Dropbox to sync my existing Notebooks, it seems to work okay. Maybe too much data. Could there be a limit somewhere? (size, notebooks, words)

Are you using the beta editor or regular editor? Is there any warning or error in the log?

I’ve tried both the beta editor enabled and disabled in the configuration with the same results.

When I can actually get to the logs and select the errors only option, I only see a message like
“can’t upgrade to database v34 - fuzzy search index will not be used, no module spellfix1”

The same error is there when I don’t configure Dropbox and the app is working.