iOS sync to nextcloud

iOS sync to nextcloud fails with message “Network request failed”.
I have seen a few google posts with this, and I believe I saw a response (from Laurent?) with a git update quite recently.
Will this find its way into a new iOS app release? Does this fix the problem?
Note: Joplin syncs fine on desktop platforms - ubuntu.
Note: Nextcloud syncs fine with itself from desktops, and from the nextcloud iOS app on the same iphone on which Joplin does not sync.

Yes I’ll try to make an iOS release very soon since I indeed forgot I hadn’t made one with this fix included.

Thanks Laurent. I updated my iOS Joplin app to v10.0.29. The same problem exists. I have re-checked everything. As a ref point, qownnotes syncs fine from the same iOS device to the same nextcloud instance.
The Joplin logs show a bunch of value@/var/containers … error logs in red font. I am willing to send these logs to you, but I would need the procedure of getting them out of iOS :).
Regards, Stan

1 Like

If you could take a screenshot that should be enough. Most likely only the first few lines of each error are needed.

Here is a shot of the error

Let me know if you need any other tests done, etc.

Stan

1 Like

Is there anything further on this? Can I help in any way?

I noticed another iOS update and tried again, but still has the same error.
I guess this will end my queries.
It does not function on my iOS.
It looked like a nice app.

I’m getting similar errors on IOS using WebDAV, and freezing using Dropbox and OneDrive. It looks like Joplin may not be suitable for mobile use if you’ve got notes with a large number of attachments.

I’m having a similar issue with WebDAV and reported it on github. https://github.com/laurent22/joplin/issues/3266