Installing Desktop on Arch


I have (finally) noticed the following:

On Linux, the recommended way is to use the following installation script as it will handle the desktop icon too:

wget -O - | bash

I am on the following:

leigh@T16-AL ~ % neofetch
                   -`                    leigh@T16-AL 
                  .o+`                   ------------ 
                 `ooo/                   OS: Arch Linux x86_64 
                `+oooo:                  Host: 21BVCTO1WW ThinkPad T16 Gen 1 
               `+oooooo:                 Kernel: 6.2.13-arch1-1 
               -+oooooo+:                Uptime: 12 hours, 43 mins 
             `/:-:++oooo+:               Packages: 1041 (pacman) 
            `/++++/+++++++:              Shell: zsh 5.9 
           `/++++++++++++++:             Resolution: 1920x1200 
          `/+++ooooooooooooo/`           WM: i3 
         ./ooosssso++osssssso+`          Theme: Adwaita-dark [GTK2/3] 
        .oossssso-````/ossssss+`         Icons: ArchLabs-Dark [GTK2/3] 
       -osssssso.      :ssssssso.        Terminal: xfce4-terminal 
      :osssssss/        osssso+++.       Terminal Font: Monospace 12 
     /ossssssss/        +ssssooo/-       CPU: 12th Gen Intel i7-1255U (12) @ 4.700GHz 
   `/ossssso+/:-        -:/+osssso+-     GPU: Intel Alder Lake-UP3 GT2 [UHD Graphics] 
  `+sso+:-`                 `.-/+oso:    Memory: 4183MiB / 15695MiB 
 `++:.                           `-/+/
 .`                                 `/

Will the above wget work on my system?

I dont want to just try as it takes a long time to sync all my notes on a new install

Currently I use:

aur/joplin-desktop 2.9.17-2 (+243 5.14) (Out-of-date: 2023-04-04) (Installed)
    A note taking and to-do application with synchronization capabilities - Desktop
1 Like

Hi, I am not sure about your system, but I have been installing this via wget the entire time and it worked for me flawlessly. Also now I am on Endeavour OS which is Arch based distro.

Thanks @tury
I know EOS - my mum has been using it for the last year - great distro
I will try it on one of my old laptop ArchLabs installations

Well, that worked :slight_smile:

I uninstalled my existing version then ran the command and changed the line below in my i3 config and Joplin started up with all my notes already there!

# Start Joplin
bindsym $mod+j exec /home/leigh/.joplin/Joplin.AppImage

The only thing I am not sure of now is how updates will now work, as this was not installed via pacman or yay

Just run the command again. If you look at the wget command it downloads a script called This checks for an installed version and if it finds that there is a newer full release it will download and replace the AppImage. If Joplin is running you will have to quit it and restart to allow the new AppImage to take over.

It's a manual process, you will not be prompted when a new release version comes out.

1 Like


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.