Installation script output seems ok but joplin desktop not found

Using ubuntu Eoan, tried installing joplin desktop latest version as of today following instructions from github page. Gnome desktop

Output message just draws “Joplin” on terminal and then I tried to open joplin to no avail. No icon is available. Seems that there’s no joplin installed.

what am i doing wrong?

attached capture

which joplin will only show you the “joplin terminal version” and not the joplin desktop version.

11:42:03 [foxmask@foxmask-G3-3579:~] $ which joplin
11:42:08 [foxmask@foxmask-G3-3579:~] $ /usr/bin/joplin version
joplin 1.0.161 (prod)

don’t you find the icon of joplin amoung the gnome apps ?

No icon available. I’ve tried to launch by command line to no avail. I can not find the executable

From your screenshot it looks like the installer hasn’t run. After the ascii art “Joplin” is displayed you should see Joplin being downloaded and set up. This happened to me recently when upgrading a Linux Mint laptop. I ran it a second time and it fully ran and completed the install / upgrade.

Yes, I’ve noticed the lack of installation messages too. But no matter how may times I run the install, no message is shown. there is no icon on my desktop and the app is not even in the list of the installed apps


open the downloaded script
comment “architecture check” code block
execute script

Now joplin is working ok

I was just drafting a message suggesting that!!! You beat me to it…

Got the script to work by downloading it and just running it locally, without any editing needed.

There is an open GitHub issue (#2906) about this problem.

Can you please share the output of runnning uname -a on your computer, I think that might be why it’s quitting out early.

Also are you using a different shell, like zsh or fish?


For info the script did not work for me on a test VM using Linux Mint 19.3 unless I ran it like ./

Running the script using bash or piping it to bash halted after the ascii art without any errors.

Thanks for checking @dpoulton I was actually running it off the live disk and it worked no problem, but once I went through with the full install it failed :thinking:

update: Okay I was able to reproduce it, but it isn't consistent. Sometimes is fails and sometimes it works

For anyone that can reproduce this issue, could you try the below command and send me the output?

wget -O - | bash