In order to synchronise, please upgrade your application to version 3.0.0+

Operating system

Windows

Joplin version

2.14.22

Desktop version info

Joplin 2.14.22 (prod, win32)

Client ID: 43a73dd5b8ee46d8a5d81e986a9c288f
Sync Version: 3
Profile Version: 46
Keychain Supported: Yes

Revision: e579eb9

Backup: 1.4.0
Note Tabs: 1.4.0

What issue do you have?

I am now getting a message "In order to synchronise, please upgrade your application to version 3.0.0+".

When I looked at the changelogs after the first upgrade message appeared, I chose "Skip this version" because the Android changelog didn't have a released version.

With this message that appeared today, I must upgrade in order to sync between computers!

Will a prod version of Joplin for Windows sync with Joplin for Android v. 2?

Thanks,

John

All clients need to be on version 3 as the sync target will have been upgraded. All major platforms via the official release channels have the new version now.

Thanks @Daeraxa. My phone now says it is running 3.0.7 (prod, android). However, there is no 3.0.7 (prod, android) in the Android Changelog.

For those of us who update apps manually, can we get a bit of warning that something like this is coming? Getting a message that sync doesn't work and there is no prod version in the Android Changelog - by the way, it still says android-v3.0.7 (Pre-release) - was worrisome!

Thanks,

John

PS my sync is working again! Thanks very much!

I'm not sure why the changelog says that to be honest, 3.0.7 is the "latest" release and is tagged as such - maybe because it is done from the tags rather than releases. However, if you are using the play store for Joplin I'm pretty sure it only ever has full releases available - pre-releases are generally managed by installing the apk directly.

I know the releases were all timed to make sure that they were available on all platforms at the same time, what kind of warning do you mean in this sense?

This is what the Android Changelog says:

Something like "In a couple of days time, version 3 will be required in order to sync. Production versions are available on all platforms.".

Thanks again,

John