If you have an issue with encryption please read this!

Encryption was recently upgrade to use AES-256 so any app you upgrade will start using this. The problem is that apps you do not upgrade will see these encrypted notes, and will not know how to decrypt them. That will result in encryption-related errors such as a Unknown decryption method.

  • First, there is no risk for your data. It cannot currently decrypted but it still there and it is not corrupted

  • To ensure you can decrypt those notes, make sure you update all your apps. If you did so, and it still doesn't work double-check your version number. It should be:

    • Desktop: 2.11.11
    • Android: 2.11.1
    • iOS: 12.11.5
    • CLI: 2.11.1
  • All the official releases are up-to-date however some non-official channels have not updated their releases. In that case, contact the developer for that channel, or directly install our official release.

  • Once you start the upgraded version there may be some items that need to be manually processed for decryption. To do so, in the desktop app, go to Help => Sync status and click on "Retry all". In the mobile app, go to to the configuration screen, scroll down to the "Sync status" button, then press "Retry all".

Any question, feel free to ask here!


Upgraded to Android Jopin 2.11.27 from F-droid just now. "Retry all" button gives no response. Clicking "retry" for each item results in items disappearing, but "encrypted" notes continue to appears as "encrypted".

1 Like

Once they disappear from that list, they should get decrypted automatically after a while

May I suggest you build in a feature to notify people about this. So if this happens in the future, you will be able to notify people about this.

This caused me a lot of trouble...

1 Like

I use the CLI and the iOS apps. Both are on current versions. I upgraded the CLI today. But I'm still seeing the encryption issue. Any clues for CLI users?


CLI 2.11.1; iOS 12.11.5

This CLI version should support the new encryption method. What is the error message?

:sweat_smile: I seem to have fixed it with e2ee decrypt --retry-failed-items. Error message is below anyway, in case it helps. Thanks, Laurent.

One or more items are currently encrypted and you may need to supply a master password. To do so please type e2ee decrypt. If you have already supplied the password, the encrypted items are being decrypted in the background and will be available soon.
You may also type status for more information.

I opened Joplin on my iPhone today and it started Decrypting all my notes (Or at least is taking a very long time). Is this expected behavior with this update?

Typically this would not be an issue but I have a lot of notes :grinning:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.