How to replace Joplin Cloud data with local?

Joplin 2.7.8 (prod, win32)

Client ID: 59d52d700241427eb379a19c50c9963f
Sync Version: 3
Profile Version: 41
Keychain Supported: Yes

Revision: 2238ef5

Windows 10 Pro 21H2 19044.1466

Several months ago I signed up for Joplin Cloud beta, tried it, and decided it wasn't for me right then. At that time, my notes were encrypted. I didn't close my account or delete my data.

Later, I using OneDrive as my sync target, I removed encryption and manually deleted the master keys from SQLite. That's been fine for months.

Today, I've signed up for Joplin Cloud and am trying to cleanly sync my existing notes and haven't been able to. I assumed the Synchronization > Re-upload local data to sync target would replace my previous cloud data. However, that's clearly not the case. Joplin pushed my notes then pulled everything from the target--exactly what I didn't want. I've ended up with 13K items, most of which are encrypted.

I can recover using my JEX export. But in my view as a user, two problems remain.

  1. How do I replace my Joplin Cloud encrypted data with only my local, unencrypted data?
  2. How can this use case be improved in the future?

What, to me, should have taken fifteen minutes has become a multi-hour odyssey. If I weren't an experience user, I might not have exported my data AND had backups AND turned off auto-sync.

I like and rely on Joplin, but if I'd trusted my data to the app and its cloud provider, I'd be in serious trouble right now. That's the opposite of how I want to feel, and the opposite of Joplin's "protect your data" value that I've seen since the app first appeared.

I'm not taking any further action on my Cloud account right now. I'll revert back to OneDrive, overwriting my local data from it (which does work).

I'm happy to help troubleshoot and try again, to improve the product. I have a full set of notes and screenshots from my sync attempt.

Before re-uploading to Joplin Cloud.

And after it finished about an hour later.

The issue is not specific to Joplin Cloud, it's just the way the app works. You have full access to your data so if you want to delete everything, simply sync with Joplin Cloud, select all the notes and delete them. You can also use the Victor plugin to help with that.

Once that's done, just restore your backup and sync again. I think users are sometimes overthinking all this - if you want to delete your notes, just do that and sync. There's nothing more to it and no need for complicated operations with the sync target.

The issue is not specific to Joplin Cloud, it's just the way the app works.

What's specific to Joplin Cloud compared to Dropbox, OneNote, or a local file store, is with those I can delete the Apps folder and start fresh with my backup. That's exactly what I did to get to a clean state.

If the Apps folder isn't deleted, the info.json file is, as I'm sure you know, synced from the target. There's no way I've found to overwrite it. That's what contains the encryption keys.

simply sync with Joplin Cloud, select all the notes and delete them. Once that's done, just restore your backup and sync again.

That's what I did. And on my Android phone I deleted the storage cache and data, uninstalled, and reinstalled Joplin, then synced with the Cloud.

Here's the result on my Desktop.

I ended up with my master key entries again, which were only stored remotely. (this screenshot is after I reentered my master password because of the mobile sync problem below).

On mobile, after the first round of sync, I had this. Note the Not Downloaded.

I had to enter my old master password on mobile (maybe desktop) in order to download all attachments.

Resulting in this. Note the number of tags? I do not have 193 tags. I have 3.

Because the mobile and desktop sync information don't match, I simply can't trust that my data is stored correctly. Worse, despite deleting all notes in Cloud, I was required to reenter my old encryption password in order to fully sync on mobile--but not desktop.

I promise I'm not a neophyte when it comes to software. I'm a 25 year veteran software engineer. I don't agree I'm overthinking anything. I'm of course not contradicting you in how Joplin works, or even asking you to change it. All I'm asking is for you to delete all my data and settings in Joplin Cloud so I can start fresh just as I did with Dropbox.

After corresponding with Laurent, I decided to delete my data, close my Joplin Cloud account, wait for the account data/settings to be completely deleted (no idea how long that will be), then create a new account and start fresh.

To reduce where my data is, I decided to delete my data in Joplin Cloud using the simple steps recommended by Laurent. The results were . . . unexpected.

  1. Synchronization > Switch to Joplin Cloud sync target and Apply (disabled synchronization interval, disabled Note History)
  2. Synchronization > Delete local data and re-download from sync target
  3. I was prompted for and entered my master encryption password
  4. After sync complete, I deleted each notebook.
  5. Then, Synchronize to delete remote items.
  6. After that was complete, as a test I once again chose 'Delete local data and re-download from sync target'
  7. Should have been zero, right? Surprise: Joplin fetched 12,000 items, created 5,255 local items.
  8. Weirdly, no notes showed in Joplin. But resource files existed in .config/joplin-desktop.
  9. So, what happens if I export a JEX? "No notes to export" message.
  10. What if I choose Tools > Note attachments? Thousands of entries. Why weren't these deleted when there's no related note?
  11. Installed Victor plugin. Restart. Tools > Delete all data. There go the 2506 resources and 193 tags!
  12. Checking .config/joplin-desktop, still 1322 resource files (732 with a .crypted extension)
  13. Synchronize. Deleted 2699 remote items. Fetched 2699 items. Sigh. Did it really fetch?
  14. Synchronize. No change. Good.
  15. Again, Tools > Delete all data. "All items have been deleted." Good.
  16. .config/joplin-desktop, still 1322 resource files (732 with a .crypted extension)
  17. 'Delete local data and re-download from sync target' Should be nothing.
  18. Created local items: 2556. Fetched items: 10880. From where??? Everything was supposed to have been deleted.
  19. Tools > Delete all data. "All items have been deleted." Well, I don't believe you.
  20. 'Re-upload local data to sync target'. I really, really wish this meant "replace sync target with local data"
  21. Created local items: 783, Created remote items: 1773, Fetched items: 12653 From where???
  22. I give up.

It's apparently impossible to delete all my local and remote data using Joplin. If it's actually been deleted, I can't be confident it has been. That's remarkable. And I'm not happy that my Jopliln Cloud account will be fully deleted "after some time" and not know how long that is.

I get that encryption and sync are hard. But when it comes to my data, it's got to be:

  • Easy to protect
  • Easy to replace
  • Easy to delete
  • Easy to confirm all of the above

After three days of effort to protect, replace, and ultimately delete my data, I'm sorry I ever tried Joplin's E2EE along with Joplin Cloud.

It's been terribly frustrating, and I have to conclude that either Joplin Encryption is busted, or Joplin Cloud, or Joplin Sync, or all three.

You should probably have used the Victor plugin as was suggested so that you also get the tags deleted. The items you got were probably also note revisions. It's indeed an issue that these revisions can't easily be deleted at the moment, and I plan to do something about it.

In step 11, you'll see I did use the Victor plugin.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.