Home / GitHub Page

How to get password into terminal version

Hi folks,

I have Joplin Desktop app, and Android app successfully running and using encryption with Dropbox.

Today I installed the terminal version and all seemed to go well.

I ran sync and it completed. My problem is unencrypting the notes in the terminal version of Joplin.

joplinterminal

I tried
e2ee decrypt
and it says complete but never asked for my password.

I also tried
e2ee --password MYPASSWORD

My decryption password has spaces and a punctuation mark in it, but has worked fine with Desktop GUI and Android versions of Joplin.

How do I get the terminal version to recognize my password and unencrypt the synced notes?

Thanks for any suggestions and kudos to Joplin

Hi, and welcome on the forums! There was a bug in the latest version, which should be fixed in v1.0.140. Please give it a try and let me know if it still doesn’t work.

Thanks, for the quick reply.

I re-installed; it works fine and as expected.

ee2e decrypt

asks for the passphrase and then successfully decrypts the notes :slight_smile:

   joplin 1.0.140 (prod)