Homepage    |    GitHub    |    API    |    FAQ

How to force synchronization to a particular one drive account?

FactSheet:

  • Joplin Desktop version: 2.1.8
  • The operating system: Win10 v1909(build18363.1440)

My Android version was set to sync to One Drive account, say, acct1@gmail.com,

However, the Win10 desktop version automatically sync Joplin notes to another One Drive Account, say, acct2@gmail.com

So my question is how to force Joplin Desktop to sync to One Drive Account, acct1@gmail.com ?

Thanks for any kind of help!
hhtmp88

@hhtmp88 welcome to the forum

Do you want to keep the existing notes from both accounts, either or none? i.e.:

  • None
  • Android only
  • Windows only
  • Both

Also be aware that changing sync targets when you already have notes can get a bit tricky and no process is without risks. Steps can be taken to minimise the risk, but risk remains.

Finally, I do not use OneDrive but I have read on this forum that some people have had issues with Android :arrow_left: :arrow_right: OneDrive :arrow_left: :arrow_right: Windows syncing. I do not know if that was a real problem , is still a problem, or was due to a specific system config of the users concerned.

Would like to
Keep the notes data in Android Only.

How to do?

Thanks!

I am not sure,
but why there are no way to enter the One Drive Account info in Joplin configuration ?

Instead, Joplin get login authorization automatically!

and get One Drive be logged into an account which is NOT the one we want it to be!

If you don't want the notes on the Windows machine:

  • Close the Windows desktop client fully (File > Quit)
  • Rename your profile folder <user>\.config\joplin-desktop to, say, <user>\.config\xjoplin-desktop
  • Start Joplin, it will be reset as if just installed and a new <user>\.config\joplin-desktop will be created
  • Delete the welcome notes
  • Link the desktop client to the OneDrive account you want to use (acct1@gmail.com) and sync
  • Every note you had created on the Android device should now appear in the desktop client as they are linked to the same account
  • Copy any templates or custom css files from xjoplin-desktop to joplin-desktop. DO NOT COPY ANYTHING ELSE
  • If you have copied any css files across, close the desktop client fully (File > Quit) and restart
  • Once you are happy, delete <user>\.config\xjoplin-desktop

Does not Works!

still login automatically to acct2@gmail.com
-> any work-around's?
.
I wonder why there is NO place to enter the One Drive login credential directly in Joplin "Options" menu?

This is because Microsoft does not let you authorise Joplin to use OneDrive this way. When you set OneDrive as a connector you are shown (on first sync) a URL to click which takes you to a Microsoft login screen at login.live.com. You have to log into OneDrive / Microsoft with your username / password etc and get the Microsoft site to authorise Joplin for your account.

Joplin then gets a special token it then uses to sign in from then on.

The code from Microsoft is stored in your Joplin profile, so the fact that Joplin is apparently still logging onto the OneDrive account of acct2@gmail.com means either:

  1. You have not renamed your profile as mentioned at step 2 above (did you see the Microsoft login screen again?)
  2. You have previously used a hidden feature of Joplin to move your profile location

In Joplin Desktop go to Tools > Options > General. The very first line on the settings page starts, "Notes and settings are stored in:", what does it say after that?