How to fix “Some items cannot be synchronized” error on Joplin desktop app

Operating system

macOS

Joplin version

2.14.20

Desktop version info

Joplin 2.14.20 (prod, darwin)

Sync target

Joplin Server

What issue do you have?

I get a "Some items cannot be synchronised" error, using Joplin Cloud, latest version of Joplin macOS (as of this writing), Sonoma 14.3.1.
When I click on "View them now" I find that there is a single note larger than 250MB listed. I have searched by both filename and by note ID on the entire local drive with Spotlight search and Houdah search and neither are found, nor do they exist locally in Joplin with search. I recall deleting this note locally sometime in November 2023. This error just started after updating Joplin a few weeks ago (maybe from 2.14.14 to 2.14.17? don't remember). I have updated Joplin again since the error started and it persists, now on v2.14.20. I also have tried "Retry" multiple times including restarting Joplin after Retry. I believe for paid Joplin cloud users you should offer a private non-public log upload or an anonymized way to get public support I am surprised you want my clientID and the log.txt contains my email and joplin cloud email which is a spam and hack risk.

Screenshots


Log file

log.txt (41.4 KB)

Do you have a complete profile on some (desktop) device, and a backup of that profile ?

I have the Default profile on the desktop macOS device's Joplin. A second profile I haven't used in years. Will making a backup or creating a new profile help with this issue? The other devices I use are iOS, iPadOS, these all sync via Joplin Cloud. I rarely use the iPadOS Joplin client.

If you trust your "default" profile is complete and I have a solid backup, I would just delete all other profiles on all devices, delete the profile on the cloud (manually) and upload the default profile. I am almost certain the problem will be gone.

Thank you ajay for answering. By delete on the Joplin Cloud manually, do you mean going to Settings, Synchronisation, Advanced, Re-upload local data to sync target? Or some other steps in addition to this to first erase Joplin Cloud?

Can you think of any other workaround. Last time I installed Joplin to a new device and re-downloaded (a new iPhone) it took hundreds of syncs before it worked normally. About 595MB across 79 folders and 9,278 notes. I opened a support ticket on that and was told to just keep hitting sync for some reason many notes re-downloaded even though already there. So it was very time consuming before it worked normally on the iPhone, a second or so to sync as I rarely edit more than 3 notes a day. I am reluctant to have to delete profiles on the other devices.

No, I am not expert enough when it comes to the Joplin cloud. But I assume somebody can tell you how to get a clean slate on it. I have also never experienced such slow sync processes. That may be because I am on a high speed internet connection, or because my nextcloud server is not throttled.

I have about 530 Mbps download and 265 Mbps upload, which is fairly fast internet. After deleting on iPad and re-installing, or on iPhone and re-installing, syncs would take over 15 minutes, each time sync'd, for a week before finally returning to 1 sec - was due to some programming issue or bug with Joplin and Joplin Cloud. I opened a bug report but it was never resolved. I have found Joplin Cloud to be stable but support is not very responsive for a paid service that should integrate very well with free Joplin, so I am thinking of migrating notes to Obsidian. The folder-file structure of Obsidian seems to be less subject to user errors or software errors.