How to decrypt the encyrpted data that is synced in dropbox?

i have joplin encrypted note sync to dropbox. now i want to decrypt it, regret to encrypt it.

how to decrypt it… i tried but not working. pls refer to the screenshot below
i have disabled the encyrption and remove the password…

pls advice.

The easiest way I think it so just start from scratch: make a JEX export of all your notes, delete Joplin sync folder in dropbox, reinstall Joplin on all your devices, import JEX.

good, i will try that. so far what i have done was only half way.

i unistalled android joplin, and reinstall… that makes no changes.

hmm bad luck. can't export
what setting need to be deal with ?

even thou i can read my note just fine, that simply means it is decrypted , right ? why it still ask me to decrypt it ?
:face_with_thermometer:

see… this is how i got stuck… a lot of time wasted (whole day actually).

Did you try to set the password?

i did…

also set the same pwd on android joplin, but both doing nothing

oh correction! the android note… one of it has being decrypted. just now all 3 notes are not openable… being encrypted… after shorttime since i entered the key… one of the locked file has being decrypted on android… although it is never encrypted on linux joplin

Since your font display squares instead of icons it’s hard to tell if it’s working or not. But in any case you need to set the password for both master key. Some notes might still be encrypted with the previous (non-active) master key.

do i need to enter password on linux joplin ? seeing the notes here are totally not locked… i can open and read them perfectly… it is the android joplin that still got 2 note is locked.

Why not giving it a try?

see, i have entered the 2 SAME password…

and one is tick one is boxy. don’t know what that means.

why 2 password ? is it one from joplin linux and one from android joplin ?
so confusing

android joplin…
one note is unlocked, the remaining 2 still locked…
but in password fields, both are x…

what do they mean ?

I'm going to guess the boxy icon is actually a cross on your computer, which means you've entered the wrong password. Try again, till the icon turns into a tick.

As for the Android app, forget about it - just delete and reinstall. What you need is to export the notes from the desktop app.

i need to enter password to export ? even though all my notes are not lock …
why ?

i will just copy and paste the content of the note into mousepad… and wipe the whole notes off… then create new note and copy them back from mousepad…

Why not? How hard is it to type a password and find out? And yes you still have encrypted data, it might a be a note, a tag, a notebook, etc.

i have tried several time, i can’t get it ticked… most probably typo error when i made the password.

Well if you encrypt data and then forget the password (or make a typo while setting it), then there is very little that can be done to that data - it will remain locked that way.

yes, i know… i don’t blame the software for it.

what i felt is that password typo happens. .especially on android small touch screen… if it hide after each character of typing… high chances error occurs…
arg! never mind… anyway…

Would be real handy if turning off decryption decrypted all encrypted files, then removed the encrypted version. It's been causing problems between my devices since I turned it off.